Jump to content
Welcome to our new Citrix community!
  • 0

Keyboard works... but Mouseclicks aren't recognized

Markus Frenzel



Some of my users got a strange problem from time to time... sometimes they can't click anymore in an published app (regardless of the app) but keyboard regular input and shortcuts still work (ALT+F4, TAB, ALT+TAB, etc.).

The mouse pointer can be moved... but clicks (left or right doesn't matter) aren't recognized.

My environment: XenApp 6.5 HRP1 with installed Hotfixes (002, 007, 011, 013, 028, 033, 053, 058), Windows Server 2008 R2 (latest Updates installed).

Any suggestions?

Thanks in advance.



Link to comment
  • Answers 86
  • Created
  • Last Reply

Top Posters For This Question

Recommended Posts

  • 1



Hello all, it has been a while and I'm sure many people have found a solution. I am a clinician end user and had tons of trouble with this issue on 2nd monitor. 

If you go to Citrix --> right click "advanced preferences" --> high DPI --> "yes" 


This magically solves the mouse input. EPIC EHR, my citrix application also scales perfectly on my laptop as well as when I drag it over to the monitor. Thanks for your help everyone! 

  • Like 1
Link to comment
  • 0


Anybody got the same problem? It's very annoying to a handful users.

I've found an old problem description which points to a problem with the CITRIX Client and/or .NET Framework... but my users are working with the newest receiver and deinstallation of the .NET Framework isn't a solution for me because some local installed client software needs .NET Framework.

Any help would be appreciated.

Thanks in advance!


Link to comment
  • 0

I'm seeing this problem too, using XA Fundamentals 6.0 for Windows 2008R2.
Keyboard input is fine, but mouse input freezes. The application is a RDS desktop session.

After disconnecting from the session, and reconnecting mouse input is restored.
Did you find the cause of this problem?

So far I established:

- Serverside session is fine, there is no change in running processes after reconnecting
- Client does not need to be reboot, no re-login is needed (just clicking the application again helps)

Any suggestions?

Link to comment
  • 0


Please try the following: verify the client-address in your Citrix Delivery Services Console. Is it correct or does it show a local loopback address (

Which Receiver Version do you use?

My users are currently testing a solution approach and things are looking good so far. No more mouse problems are happening.


Link to comment
  • 0

Hi Markus,

Thanks for reply'ing! I checked sessions across two environments. Sessions show the real endpoint IP, not

Receiver versions differ, however the problem also occured using version 4.0 (the latest, dated 26/06/'13).

Could you explain me what you did to solve the problem that seems to be working so far?


Link to comment
  • 0

Hi Remco,

you're welcome!

Our first problem consists of the wrong shown IP for some of our clients. This was caused by our proxy settings. The old squid server in our environment has worked fine with the old presentation server 4.5 environment... but not with the new XenApp 6.5. After disabling the proxy settings the IP shows up with the real endpoint IP.

The next problem was caused by the self-service plugin exe which was automatically installed with the latest receiver. I avoid this by deinstalling the receiver an reinstall it with the use of a batch file and called the setup routine like this:

CitrixReceiverWeb.exe ADDLOCAL=ReceiverInside,ICA_Client,USB,DesktopViewer,Flash,Vd3d /silent

After this our mouse problem is gone...



PS: please excuse my slightly rusty english... I have to improve it...

Link to comment
  • 0

We're also seeing this issue, but apparently only when extranet users (at home) connect thru a Juniper Secure Access portal - when they connect thru a full Cisco VPN the issue isn't seen. And actually only after actively working with the application.

Local access isn't an issue either it seems.

Link to comment
  • 0

Uh... oh... strange things are happening on my server farm. After installing HRP2 the problem is back!

I've tried different combinations of the seamless flag registry key without any luck. The problem is right back and it persists!

My users are very unhappy with this situation because it's very annoying in our sales department. Customers are waiting in front of the desk of the user while he or she tries to restart his session hoping that mouseclicks are back if they reconnect to their session. Sometimes this is the right way (reconnecting to the session)... sometimes not (and I have to kill the user session).

Its not logical... keystrokes are always there... only mouseclicks arent.

Link to comment
  • 0

Still the same problem here. We were able to 'restart' the mouse without disconnecting once. We haven't had the chance to retry this. Try the following, once a user 'freezes': send a message through the console to the user, and let the user hit 'enter' to close the dialog box. The mouse starts working again.

Link to comment
  • 0

Strange behaviour... our servers (3 in the farm) are completely virtual (VMware).

At the moment I try to figure out if the error is caused by a specific application or if its located only on one servers of our farm. Months ago it happends on all 3 servers but the last times it only happens on one specific server.

Link to comment
  • 0

We are also experiencing this issue.

Running all XenApp 6.5 on vmware esx 4
Publishing full desktop in seamless mode
Launching desktop from storefront, web interface and custom ica files through netscaler

Happens significantly more with more users/load on the servers. We have 6 nodes and the mouse "lockup" happens very infrequently, however when we disable 3 of the 6 it happens within a couple of hours of users logging in.

Have clients ranging from Program Neighborhood 10 to Receiver 3.3 with online plugin

No printer, flash or windows media redirection.

Have never had it happen in XenDesktop 5.6 running same receiver client.

Sometimes when we disconnect the user it disconnects quickly sometimes it takes up to 5-10 minutes.

Since AV is always to blame anyone running or not running Symantec Endpoint protection?

Has anyone contacted Citrix Support with this issue?

I talked to Frank Marzullo from Citrix at synergy this year and he has never heard of this issue either.

Edited by: abradfish1 on Oct 24, 2013 9:57 AM

Link to comment
  • 0

Hi Guys

We are having the same problem.

XA 6.5 FP 2
2008r2 all updates

The Issue appears randomly across all client platforms, Windows7, Windows 8 and on wyse termianls .
Wether or not we are using storefront 2.1 or WI 5.4. with or without netscaler.

My own computer/session was just hit with this issue, of which our users has been telling us about for months.

Here are my findings:

The first/oldest app i opened in my session works as expected. If i close that app, the next app in line functions normally.

if i open a new app. it has the same problems.

If i click inside any other app, the app loose focus.

If i click the title bar, the app still does not gain focus, it is, how ever, possible to drag the window...

I can alt-tab between published apps, this will regain focus, and i can then use the keyboard to manipulate the app. Click anything with the mouse - and it will loose focus.

Shift+F2 does brings up fixed mode as expected - but mouse-clicks drop through to the local desktop.

if i disconnect/reconnect everything works well.

if i start another session while still having the defunct open. apps from the new session works well, apps. from the broken is still broken.

Session infomation for working and non-working apps is identical.

With or without session reliability

I hope somebody figures this out and soon :)

Daniel Christiansen

Link to comment
  • 0

Hi Daniel,


thanks for your detailed response to this topic.


Do you have Seamless Global Registry Flags set? If yes: what is the value of your SeamlessFlags REG_DWORD? I think it might could be the cause of our problem. Mine is set to 0xC8400 (FORCE RAW MOUSE EVENTS TO SERVER, DON'T SEND DISABLE, DISABLE LANGUAGE BAR AGENT, DISABLE CLIENT INFO SYNC EXCEPT WORKAREA).


I'm nearly out of ideas...







Link to comment
  • 0

Little Status Update: the problem persists even after installing HRP3.


My environment:

  • vmWare vSphere 5.1
  • 3 virtual XenApp 6.5 HRP3 Servers (Win Srv 2008 R2 with latest Updates)  in one farm
  • User logon via Webinterface (with Fatclients) and Citrix Receiver
  • User logon via Citrix Receiver for Linux 12.1 (with Thinclients)

When the error occurs my users restart their fat-/thinclients and reconnect. After the reconnection everything works fine... but from time to time mouseclicks are gone again. Even with a new session (I checked it twice that the old session was successfully ended via Citrix AppCenter) the problem occurs.


Until now I haven't seen any error message related to remote desktop or so.


@Mark: is there anything in your Event Viewer Logs which relates to the remote desktop error message you've received?


I cannot put a single Farmserver on the blame list... because every server gots this problem. Only from time to time... not on a regular basis. It's driving me nuts.


As we've got no active support contract with Citrix I'm unable to contact Citrix support to let them dig into it.

Link to comment
  • 0

We have the same problem

Citrix Xa6 windows 2008 r2 - 250 virtual servers on vmware, 1200 at ThinkClients users working at the same time
All the same servers (Link Clone on storage)
Publishing full desktop

There are 15-20 cases a day disappearing mouse buttons
Exit and re-entry to the same session returns the normal functioning

Someone managed to fix the problem?

Link to comment
  • 0

Hello Everyone,


Can you confirm your settings for the pointer scheme for the published desktop? Can you also confirm the version of receiver the client is using.

For the pointer scheme: Go to Control Panel->Appearance and Personalization-> Personalization ->Change Mouse Pointer -> Pointers->Scheme 
If this is set to Aero, change it to None or something other than Aero and test the desktop or application again. Also, what is the client machine OS that you are connecting from?


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...