Jump to content
Welcome to our new Citrix community!

Header gets deleted by Netscaler


Recommended Posts

Hello,

 

We have an sso servers that are load balanced on VPX, the sso is integrated with kerberos so ince the user log in to his machine it sso will pass through credentials to web application so the user wont be prompted with login sso login page when he wants to access web application. According to what the sso engineer told us, when the user is trying to access a web application it will show the sso login page ( it's not passing the credentials to web application). After investigating, it turns out that NetScaler is deleted "www-authenticate" header and it's value and that's what causing the issue.

i have tried to add the header through rewrite policy but i cannot retrieve the value since the value is dynamic.

Any suggestion on how to prevent netscaler from deleting and headers or content and just pass through the traffic?

i have tried no rewrite policy as well and still the same issue.

 

Note: SSO servers are used with web applications and other virtual servers, it's not related to citrix gateway or any authentication on method on Netscaler , to netscaler it's just a normal virtual server.

 

Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...