Jump to content
Welcome to our new Citrix community!
  • 1

Black Screen on Server 2022 worker


Question

Hello,
I am creating my Citrix Worker image via MECM, using a task sequence. In the task sequence I can choose between Server 2016/2019/2022, so the window-side settings are all identical. If I create a worker with Server 2019 and VDA 2203CU2 this way and deploy it via PVS, it works fine. A desktop login on the worker is possible without any problems. When I create the same worker with Server 2022 and VDA 2203CU2, I get a black screen when logging in. If I then log in locally to the console of the server, the black screen disappears and the desktop appears. But I still can not make any interactions in the session?! When I log out of the local session, the black screen appears again in the session. How can this problem be solved?

 

I am running Server 2022 with Windows Updates 06/2022 on a Citrix Hypervisor (Hypervisor Tools 9.3.1).

 

I have tried the cleanup script (https://discussions.citrix.com/topic/417832-cvad-connectionfailure-after-install-ltsr-2203-cu2-on-server-2022/page/3/), as well as disabling the WDDM driver (https://support.citrix.com/article/CTX463795/user-session-goes-to-black-screen-after-launch-when-using-windows-21h2-multisession). I did not disable the WDDM driver via GPO but via RegKey:

 

REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services" /v fEnableWddmDriver /t REG_DWORD /d 0 /f


Regards

Thomas

 

Link to comment

4 answers to this question

Recommended Posts

  • 0
On 9/15/2023 at 8:13 AM, Marc Gemp1709157697 said:

Hi @Thomas Marquardt 

 

we had the same issue. We have now only changed the order of the installations. Now we install - Citrix VDA 2203 CU3 -> Citrix WEM -> Citrix PVS -> Workspace App

Previously we had the Workspace app at the beginning and that triggered the black screen for us.

 

You can give me feedback on whether this has also helped you.

 

best regards

MG

This is positively bananas to me. I wrestled with this problem through the summer and could never figure it out. Citrix support was not helpful either.  I just had the black screen issue again after upgrading to 2203 CU4. I uninstalled CWA, rebooted the VM, and was able to log in like nothing happened. This revelation is priceless.

Link to comment
  • 0
On 12/15/2023 at 3:59 PM, Matt Sliva1709163358 said:

This is positively bananas to me. I wrestled with this problem through the summer and could never figure it out. Citrix support was not helpful either.  I just had the black screen issue again after upgrading to 2203 CU4. I uninstalled CWA, rebooted the VM, and was able to log in like nothing happened. This revelation is priceless.

Apparently uninstalling CWA and rebooting the MCS clone was a fluke. I had success with simply rebooting the MCS clone without making any changes.

 

I have encounted the issue Thomas described two times now. The first time was installing 2203 CU2 on a fresh Windows Server 2022 image. I found a work-around by first installing the 2203 CU1 VDA and then upgrading to CU2.

 

The second time is where I am at now. I had 2203 CU3 installed and upgraded to 2308 CR to test a different issue. I have no luck with removing 2308 CR and re-installing 2203 LTSR. I tried the recommendation to install CWA after the VDA but had no luck with it.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...