Jump to content
Welcome to our new Citrix community!
  • 0

French accents not recognized


Quentin Fazilleau

Question

Hello,

 

Herebelow the installations I've done recently :

- Ubuntu 20.04

 - latest Citrix Workspace app 2012 for Linux (7th Decembre 2020) through Debian packages (Full package Self Service support x86_64).

 

Since then I can't use French accents anymore such as : "éèàùôé" inside my Citrix workspace.

I've checked inside the Citrix OS preference and the selected keyboard is "French AZERTY" which should be fine.

 

All the others keys are working well. Is there any settings I should perform ?

 

EDIT :

- I've noticed that if I press "Ctrl" key I can write these letters.

- I've noticed that symbol € has the same issue

 

Thanks

Link to comment

1 answer to this question

Recommended Posts

  • 0

Hi qfazille,

Query 1- May I know which published VDA you are using or connecting to  - Windows VDA or Linux VDA?

Query 2- Version of your CVAD  and VDA?
Query 3- Which French keyboard you are using on your local machine , can you please help to put here , basically want to know any specific French keyboard variant like French AZERTY  or French  etc  ?

One of the possible solution is to use "Keyboard Sync Feature" available with Citrix Workspace app(CWA) for Linux , can try configure with below mentioned steps .

Assuming you are connecting to Windows VDA , (for linux VDA steps will be different)

 

The steps required to do changes/configure KeyboardSync feature(Keyboard re-direction) in CWA for Linux as well as on Windows VDA side.
Assuming - user has installed in a default path(with root permission) in /opt/Citrix/ICAClient/
(Non-root user default installation path : /home/<username>/ICAClient/linuxx64/86/armhf)

CWA for Linux side changes :

1. You have to modify module.ini file which resides inside path /opt/Citrix/ICAClient/config/module.ini

        (refer screenshot - module_file_kbsync_On.png)
2. You have to verify KeyboardLayout is set to (User Profile) in $HOME/.ICAClient/wfclient.ini file (Though this is a default value )
         (refer screenshot - keyboardlayout_wfclient.png)

 

Windows VDA side changes:
Please ensure below registry keys are created for Keyboard Sync feature to work. Once you configure reboot or logoff the VDA to take the configuration into effect.

 1. Perform the registry changes, please refer the article here: https://support.citrix.com/article/CTX226335

                  (refer screenshot - unicodeSetting_1.png)


2. If the VDA OS is either Windows Server 2016 or Windows Server 2019, then please below given registry:
HKEY_LOCAL_MACHINE\Software\Citrix\ICA\IcaIme, add a new DWORD value with key name DisableKeyboardSync and set the value to 0
                  (refer screenshot - unicodeSetting_2.png) (edited) 

 

 

After doing above steps , keyboard selected on your client machine/laptop will be synced to the published VDA , i.e if you have selected French keyboard on your local machine , same keyboard will be synced to your published VDA . This helps is resolving the key mapping issue.

 

Let me know if this resolves your issue.

 

Thanks!!

Shakti

unicodeSetting_1.png

unicodeSetting_2.png

module_file_kbsync_On.png

keyboardlayout_wfclient.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...