Jump to content
Welcome to our new Citrix community!
  • 0

Application crashes only in ICA-sessions


David Harrysson

Question

Hi,

 

We have a locally developed application that we have run for multiple years without any issues in our XenApp 6.5 environment on Server 2008 R2.

However they now updated the program and after that the applications crashes every single time when you close down a journal (it´s an applications for hospital use).

The strange this is that it only happens if you run the applications through a citrix-session. If you RDP to the server you can run the application without issues.

We are also installing a XenApp 7.15 LTSR environment on Server 2016 and it crashes there to on the same manner.

 

Here is what I have tried:

Run as different users

Run as admin

Disabling Trend Micro Antivirus

Running it from a published desktop from a command-line-prompt

Running it stand-alone as a published app.

Tried different versions of Citrix Receiver (4.1 and 4.9 LTSR and 4.12)

Disabling Citrix API-hooks

Disabling/enabling DEP.

 

Here is what the applications own log throws:

Exception:
--------------------------------------------------------------------------------------------------------
  2.1 Date          : Thu, 22 Aug 2019 11:07:20 +0200
  2.2 Address       : 02B5D18F
  2.3 Module Name   : PMO.exe - (PMO Client )
  2.4 Module Version: 11.0.1.311
  2.5 Type          : EAccessViolation
  2.6 Message       : Access violation at address 02B5D18F in module 'PMO.exe'. Läs of address 00000369.
  2.7 ID            : EC13ACF7
  2.8 Count         : 1
  2.9 Status        : New
  2.10 Note         : 
  2.11 Sent         : 0

Link to comment

2 answers to this question

Recommended Posts

  • 0

just to confirm what method did you use to disable API hooks? the fact you see the same issue in different versions of citrix / OS'es makes it sound like its that

 

Took these steps from an earlier related thread - if you haven't followed might be worth trying

1. Download Process Explorer from Microsoft
2. View Lower Pane ~ Dll's
3. Run your troublesome app (leave the app error open)
4. In Process Explorer highlight the App and view the Dll's
5. Regedit and navigate to [HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxHook\AppInit_Dlls]
6. Export [HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\CtxHook\AppInit_Dlls] to your deskop
7. Delete the keys (ActiveSync, Multiple Monitor Hook, etc..) ONE AT A TIME rerunning the App each time to see if it finally opens. Once it opens you know what Key (Hook) is causing the problem.
8. Run the file you created in Step 6
9. Delete the key that you determined to bee the problem in Step 7

Link to comment
  • 0

Thanks for the input John.

However this issue was related to a centrally configured setting. A feature was enabled that was not supposed to be and this feature was not installed on the clients/on Citrix Environment. Why the application crashes only in Citrix and not on other clients is beyond me though. When the feature was disabled the crashes stopped.

 

The only thing I can Think of is that we have disabled DEP in out Citrix Environment. With DEP enabled another software crashed all the time so we found that disabling DEP sorted out the issue.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...