Jump to content
Welcome to our new Citrix community!
  • 0

Slow speed through client mapped drive

Martin van der Meer



I have a Win 2008 R2 with XA 6.0 and connecting client drives at logon.
Accessing published desktop is done through Online Plugin.

When i want to copy paste somhting from client drive to server mapping it is very slow.
Like 1 KB/sec or slower.

I have read the article http://support.citrix.com/article/CTX123995 and enabled Asynchronous writes in the XA policies, but it is not helping.

How knows a solution?



  • Like 1
Link to comment

Recommended Posts

  • 2

In our situation it looks like it is a DNS issue. As soon as the Citrix server is able to resolve the client name, performance is as it is supposed to be. (I Don't know if this has an impact but we have multiple nics on our citrix servers: mgmt & prod)


Has anyone checked if there is a host-record in DNS named "client", associated with any PC?

In our case there was such host-record. After deleting this record, the access on the mapped drives is fast again.


Apparently the drive mapping functionality relies on the availability of \\Client\C$ etc.




  • Like 2
Link to comment
  • 0

HI Martin,
do you have problem on the LAN ? or are the clients connecting via WAN ?
how much latency do you see? (eg ping the server from the client pc)

copying from the client to the server wont be any faster even if you turn on the async write. this feature is to buffer WRITE to the client mapped drive, not client->server.

Link to comment
  • 0

Hi James, thanx for the answer.

I have tested it on the LAN and everything is working fast, Upload and download through a client drive is working fast.

The problem occurs when the users are on the WAN connecting for example through the Web Interface.
Uploading and downloading veryvery slow (like 1KB/sec or less). Also the window for copying process takes a long time on Calculating.....

Pinging to the server from the client results in a 9 ms.

Everything is done through a VPN connection.

When users do not use the client drive feature and just copy something to or from the server (UNC path) it works a lot faster.

Thanks in advace.


Martin van der Meer

Link to comment
  • 0

We have seen issues in the past where VPN clients or firewalls incorrectly handled negotiating the MTU value at the TCP/IP level that would cause this type of behaviour. Try setting your XenApp servers to use a lower MTU value (something like 1360 instead of the default 1500) and see if this helps. This can be done via a registry setting on your XenApp servers. Google "Windows MTU" for info on the registry key to configure.

Link to comment
  • 0

I can't see the relationship with the MTU size because it is only within a Citrix session. If a client is sending or recieving files by typing the UNC path of the server, everything works a lot faster.

I have tested with MTU 1452 on the server, but no difference.

It have to be something within Citrix or the client drive technology i think.



Link to comment
  • 0

Same situation.
Slow up-/download to USB device (up:27 MB/min, down:22 MB/min). With RDP connection up:547 MB/Min, down:235 MB/Min.
We don't need so much, but a a litte more would be perfect. :-)
Setting Citrix policy with-/without bandwith limit and asynchron/syncron write doesn't increase the speed.
XenApp 4.5 R6 on XenServer 5.6 FP1 (Intel CPU)
Online Plug-In
internal LAN 100Mbit Client / Server: 1 GB

Link to comment
  • 0

Hi, i have same Problem:
XenApp 6.0 Server
Client Windows 2000 with Client v.

- Same Problem in WAN & LAN (100 Mbit)!
- Copy from Local HDD (\\client\c$) to citrix session= OK! (fast)
- Copy from Local USB (\\client\d$) to citrix session = Very Slow !
- USB Formatted in Fat 32 and NTFS
- USB from Kingstone, LG, EMTEC,...
- Copy from Local PC D: to C: = very Fast (NO ICA COPY, only local)
- Ica Policy "Use Asynchrounus Write" Actiwated but Problem not solved.
- If the copy is Aborted, on Firewall i see the ICA traffic goes!

Many Thanks

Link to comment
  • 0

Same issue.....Server 2008 R2, XenApp 6.5, receiver 13.

WAN access to anything on the local machine is VERY slow (1kb/s). Eventually locks up the session and even the machine. When looking at processes on the XenApp server, the server seems to be not doing anything (CPU/Memory not doing anything).

Anyone? This is a major issue for our clients.


Link to comment
  • 0

I too have the same issue with new Xenapp 6.5 & 2k8R2, very slow transfer speeds over a session in Malta with a local drive on the pc. Transfering 2Mb file is very hit and miss, sometimes works after 10 minutes, mostly crashes the session, even with banwidth management enabled. The still has access to our PS4.0 farm which file transfer works perfectly.

I will look into Asynchronous write policy, see if that makes any difference. Please help if anybody has managed to resolve this scenario.

Link to comment
  • 0

Looks the issue I am experiencing is related to the version of CSG (3.3) rolling back to 3.2 resolves the issue, which is related to 'cryptographic security of the SSL connection has been compromised' messages occuring exactly when users try to transfer file from server drive to local pc session drive. I will let you know the outcome post CSG downgrade to 3.2.


Link to comment
  • 0

We have dropped to version 3.2 of the CSG and published "Ultra Explorer" instead of Explorer.

The sessions are no longer disconnected and the transfers complete in a reasonable time.

We are running XenApp6.5 and were seeing disconnects and really slow transfer speeds between Citrix Servers in the UK and a remote users C:\ Drive in Spain.

Hope that helps - If someone else is able to test and reply back that might confirm it as a workaround?


Link to comment
  • 0

There is plenty of information about this issue found here:

So far replacing the file sslsdk_b.dll version on CSG v 3.2 seems to fix XA6.0 but from my testing does NOT work with XA 6.5.

You can find that version of the file sslsdk_b.dll in the XA6.0 Rollup found here: http://support.citrix.com/article/CTX130473

If anyone can find out what is different between XA6 and XA6.5 and why XA6.5 is not working please post!

Edited by: dsterkenburg@qnectus.com on Jan 30, 2012 5:31 PM

Link to comment
  • 0

I'm having this exact same issue. It seems to be more of a problem with ADSL2+ connections when uploading only.
Even just right-clicking on the file from the local client drive, takes ages to display the shortcut menu.
I'm know RDP client mapping doesn't have any problems, so why would citrix have performance problems...??

I have a XA6.0 Farm running on Windows2008R2 servers. Using a Netscaler VPX.
There must be some sort of policy clash which causes this within the citrix session.
I have 8Mbit set as a Overall session bandwidth limit and set the file redirection bandwidth to 50%.
I have tried playing with different settings in the policies, I've also enable and disabled the "Use asynchronous writes"
No luck! Best performance I get can for uploading is 1KBps

I tried the Ultra Explorer. That seemed to improve the rightclick of the files, but copying was just as slow.

I also tried disabling "Remote Differential Compression" from the Windows features on/off setting on the local windows 7 client. No Good!

Anyone know what causes this problem? Citrx are you aware of this problem??

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...