Jump to content
Updated Privacy Statement
  • 0

Chrome "Aw Snap" issues



Hi all

We are having issues with users getting the Chrome "Aw Snap" error in their HSD and VDI sessions. 

With this failure mode being SO general and the base response from Google being less than useful (restart tab\restart Chrome\update Chrome\reinstall Chrome) we are struggling to get a direction.

We are in an information gathering mode currently and no single issue \ application \ website \ user group showing a potential issue.

We do see several websites taking almost 1GB of RAM just to run which is crazy (https://www.realestate.com.au/) and for a few users, we have asked for a process dump having 20-30+ Chrome processes running at the time of the issue.

Our current approach:

  • Gathering process dumps of users having this issue.
  • Looking at:
    • Setting Memory Saver setting to on, we are setting this on via GPO once the change control is complete... we thought this was on :-( 
    • Building a UAT VDI DG with Firefox and have 10-20 users test if they have any issues (we are a Google shop and this is unpopular) 

Has anyone found a direction \ switch \ way to tackle this issue?

Background Citrix Environment Settings:

  • Citrix Cloud
  •  HSD - Windows Server 2016 (Pooled) (10 users max 8xvCPU\32GBvRAM)
  •  VDI - Windows 10 (Pooled) (4xvCPU\10GBvRAM)
  •  Latest Chrome version every month 
  •  Majority of software in the business is delivered via Chrome i.e. SaaS 
  •  Our profile management is UPM, with the following Chrome exclusions:
    • SyncExclusionListDir56=AppData\Local\google\chrome\user data\default\jumplisticonsold
    • SyncExclusionListDir57=AppData\Local\google\chrome\user data\default\jumplisticons
    • SyncExclusionListDir58=AppData\Local\google\chrome\user data\default\cached theme images
    • SyncExclusionListDir59=AppData\Local\google\chrome\user data\default\cache
  •  Issues have been happening for a long time > 12 months but new internal software is getting more issues forcing a more determined investigation.
  • Current switches for Chrome in both HSD\VDI "--disable-infobars --disable-gpu", I believe disable GPU is not required now and is legacy setting.
  • Chrome is x64 and current version is 124.0.6367.201
  • Chrome Memory Saver settings are off.



Link to comment

2 answers to this question

Recommended Posts

  • 0

Hi Jeff

I have found that we disabled the "memory saver" functions. I am in the middle of getting this setup now and getting it into a UAT environment. 


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...