Jump to content
Welcome to our new Citrix community!

Beacon check = location is none


Recommended Posts

We've been fighting this issue for a few days this week.

Users connect via the Workspace app (2203cu5) to a Gateway. On reset the workspace app allows one auth pass (nfactor radius) but the app never enumerates the apps and fails with either "Cannot Complete your request" or "Your apps are not available at this time.  If we just close the workspace app and reopen it will sit and spin until it times out. Looking the the receiver logs, we it attempt a beacon check and starts with decideing and eventually gets to the point where the log reports "Location for store 4191981706 is NONE" and Location for URL is NONE. 

We have an open case with Citrix on this but they've not been too helpful so far. We initially saw this issue on Monday, but it went away on it's own (chalked it up to lingering DST change) and worked the rest of the day on Monday, then we got hit with it again on Tuesday. Worked with Citrix who found a deprecated expression in our receiver session policy, which we removed and things started working at once. We felt confident that it was the issue. We went all day on Wednesday with no issues (we were watching the receiver logs all day) How yesterday(Thursday) it started again, worked all day with Citrix and they are analyzing logs and such but they seem to not have seen this before.

Before Monday everything everything was working without issue on this gateway and has for months without any changes to this gateway or our basic setup.

Browser works fine and has no issues, which is our workaround and while I want to just make that the only supported method of lauching Citrix resources that's a fight for another day. We have also discovered that its only affecting the Windows workspace app and Linux(on igel) workspace app. The workspace app on the Mac's is not affected.  Internally this isn't affecting anything but then inside the network it goes through a gateway only to connect directly to the internal storefront server.

Has anyone seen this before? Or have any ideas of next troubleshooting steps we can attempt, or some buried log that might have an crumb for us to follow?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...