Jump to content
Welcome to our new Citrix community!
  • 0

Teams 2.0, New Teams on 2022 server, non-persistent PVS - UPM requirements


Tony Rallo

Question

I've been doing a lot of testing with the new teams client and I am still not able to get the UPM quite right.  I'm running CVAD LTSR 2203 CU4 across the board on 2022 server. PVS is used to deploy 2022 server hosted shared desktops.  I've followed the Microsoft guidance here:  https://learn.microsoft.com/en-us/microsoftteams/new-teams-vdi-requirements-deploy

 

I have teams installed as described in the above link, reg keys set for webview and auto update, and I have the UPM inclusions/exclusions set as follows

 

  • Inclusions from MS KB
    • AppData\Local\Packages\MSTeams_8wekyb3d8bbwe\LocalCache\Microsoft\MSTeams (directory)
    • AppData\Local\Publishers\8wekyb3d8bbwe\TeamsSharedConfig\app_switcher_settings.json
    • AppData\Local\Publishers\8wekyb3d8bbwe\TeamsSharedConfig\tma_settings.json
  • My additional inclusions
    • AppData\Local\Packages\MSTeams_8wekyb3d8bbwe\Localstate (directory) - This directory is empty and I do not know why it needs to roam, but if it is not roamed teams seems to load as a first time launch at every logon (no setting changes stick)
  • Exclusions from MS KB
    • AppData\Local\Packages\MSTeams_8wekyb3d8bbwe\LocalCache\Microsoft\MSTeams\Logs

    • AppData\Local\Packages\MSTeams_8wekyb3d8bbwe\LocalCache\Microsoft\MSTeams\PerfLogs

    • AppData\Local\Packages\MSTeams_8wekyb3d8bbwe\LocalCache\Microsoft\MSTeams\EBWebView\WV2Profile_tfw\WebStorage

  • My additional exclusions (the following house 1,000's of very small files that increase UPM load times significantly)

    • AppData\Local\Packages\MSTeams_8wekyb3d8bbwe\LocalCache\Microsoft\MSTeams\EBWebView\WV2Profile_tfw\Code Cache

    • AppData\Local\Packages\MSTeams_8wekyb3d8bbwe\LocalCache\Microsoft\MSTeams\EBWebView\WV2Profile_tfw\Cache

    • AppData\Local\Packages\MSTeams_8wekyb3d8bbwe\LocalCache\Microsoft\MSTeams\EBWebView\WV2Profile_tfw\Service Worker\CacheStorage

 

After all of this, Teams works almost perfectly, with only one caveat that i cannot overcome.  When you logon to a VDA and open teams, you get a toast notification that says, "Microsoft Teams (work or school) is now configured to run when you log in....".  If you log off and back on, it does not load automatically and when you launch it, it again pops the same message.  The ONLY way that i have been able to resolve this is to enable the policy to disable automatic configuration for UPM and roam usrclass.dat* - this file will not roam, even if explicitly set, when automatic configuration is enabled.  My understanding is that you absolutely do not want to roam usrclass.dat due to start menu issues when roaming and that is why it is hard coded to not roam when automatic configuration is enabled. 

 

All of this to ask.....has anyone else had this issue and do you know how to overcome this annoying obstacle?  

  • Like 1
Link to comment

8 answers to this question

Recommended Posts

  • 1

After some additional testing with UPM 2311, it appears that usrclass.dat is now roamed by default when using automatic configuration.  This has always been a no-no and i have reached out to Citrix for clarification, but 2311 with usrclass.dat roaming does resolve my issue.  

  • Like 1
Link to comment
  • 1

I got confirmation from Citrix that the new guidance is to mirror appdata\local\packages and roam usrclass.dat* on Server OS's for all versions of UPM.  Previously, the guidance was to exclude them on server OS's and only roam on desktop OS's.  2311 UPM will do this with automatic configuration enabled, but previous versions will not, even if explicitly specified.  Automatic configuration must be disabled and you will have to specify the packages directory be mirrored and usrclass.dat* be roamed.  I've asked that their documentation be updated because it still states the complete opposite for versions of UPM prior to 2311.  

  • Like 1
Link to comment
  • 1

I only upgraded the UPM to 2311, not the VDA.  I believe you can use the LTSR UPM, but you'd have to disable automatic configuration and set up mirroring of appdata\local\packages and the roaming of usrclass.dat*.  I have tested this and it does appear to work, however you give up the automatic configuration.......which may not be a huge deal, but i've always used it and i didnt want to disable it in case it is doing something that i am not aware of, and is needed.  

 

Citrix also suggests enabling the accelerate folder mirroring policy.  However, i have tried this and teams errors out every time you attempt to run it.  I have not dug into this piece yet - i've just kept that policy off.  

  • Like 1
Link to comment
  • 0

Thanks for this info Tony, CVAD LTSR 2203 CU4 is what we're running across the board as well. 


To clarify, in order to get Teams 2.x + UPM to work successfully have you had to upgrade your UPM server to 2311? 
Have you had to upgrade the VDA to 2311 as well?

Link to comment
  • 0

I upgraded UPM to 2311 and found I must not enable "Disable automatic configuration" policy. mirroring of appdata\local\packages and the roaming of usrclass.dat* are not sufficient to make Teams working. Maybe UPM has done other undocumented automatic configurations.

Link to comment
  • 0

Thanks for the additional exclusion recommendations, they've helped me out.   

To get rid of the annoying Startup App Notification pop-ups, I've enabled this registry setting via GPP:

HKCU\Software\Microsoft\Windows\CurrentVersion\Notifications\Settings\Windows.SystemToast.StartupApp\Enabled=0

image.png.595204a50bef57d21dcbe90ef87d3b6e.png

This will get rid of it for all apps, not just Teams.

Cheers.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...