Jump to content
Welcome to our new Citrix community!
  • 0

Ubuntu VDA not registering on DDC

Ryno Hugo


Hi All,


I have a home simulation where I am trying to help a client with steps (simulating) Ubuntu VDA's.


I am using easy install and followed steps found here  - https://docs.citrix.com/en-us/linux-virtual-delivery-agent/current-release/installation-overview/create-domain-joined-vdas-using-easy-install


when I run the xdping command after successfully doing the ctxinstall
("ctxinstall.sh has executed successfully".)
All the checks is passing with xdping, on the last step I can see the following.
("[ERROR]: DDCProbe: Failed host probe: Citrix-lap.hugo.co.za:80: timed out
Traceback (most recent call last):"

Here is a snip from the vda logs on Ubuntu side.
"[2023/12/05 16:35:56.6809380] [BrokerAgent] [Error] RegistrationManager.AttemptRegistration: Could not register with any controllers. Waiting to try again in 120000 ms. Multi-forest - False
[2023/12/05 16:35:56.6813193] [BrokerAgentAoTracing] [Error] REGISTRATION Failed registration: VDA machine SID: S-1-5-21-2063626492-3533184214-3736376000-1116, Broker IP: UNKNOWN, Error: Could not register with any controllers. Waiting to try again in 120000 ms.
[2023/12/05 16:36:13.5262367] [BrokerAgent] [EntryExit] Enter: StackManager.EnumerateSessionKeys
[2023/12/05 16:36:13.5262623] [BrokerAgent] [EntryExit] Enter: StackControl.EnumerateSessionKeys
[2023/12/05 16:36:13.5265906] [BrokerAgentAoTracing] [Information] BROKER AGENT -> HDX STACK Enumerate Sessions Request: Transaction unique ID: f7add9c0-67ce-439e-a587-bb3412332fc2, VDA IP:
[2023/12/05 16:36:13.5266586] [BrokerAgent] [Information] VdaMetaData.SessionMetaDataAuditMethod - Waking up...
[2023/12/05 16:36:15.0634606] [BrokerAgent] [EntryExit] Enter: CommandQueue.AddToCommandQueue - Adding message - urgent: False, componentName: Monitor, commandName: Monitor, commandQueuePayload: 2023-12-05T14:36:14.0616095Zfalse2023-12-05T14:36:001285193113.640971386880.48488134
[2023/12/05 16:36:15.0634750] [BrokerAgent] [Error] CommandQueue.AddToCommandQueue - CbpVersion: UnInitialized not CBPv1_5, ignoring call to AddToCommandQueue"

Firewall is off on both the DDC and also the linux vda (ip tables also disabled)
DNS is not a issue as lookups work for ddc, vda, and dc.

I have a Windows machine on the same test environment and working with no issues.

Versions is CVAD 2208, same for Ubuntu with 22.04

You have an idea of what can be wrong?


Link to comment

9 answers to this question

Recommended Posts

  • 0

root@ubuntu8:/opt/Citrix/VDA/sbin# dotnet --info
.NET SDK (reflecting any global.json):
 Version:   6.0.125
 Commit:    e898a826c2

Runtime Environment:
 OS Name:     ubuntu
 OS Version:  22.04
 OS Platform: Linux
 RID:         ubuntu.22.04-x64
 Base Path:   /usr/lib/dotnet/sdk/6.0.125/

  Version:      6.0.25
  Architecture: x64
  Commit:       492abbeef0

.NET SDKs installed:
  6.0.125 [/usr/lib/dotnet/sdk]

.NET runtimes installed:
  Microsoft.AspNetCore.App 6.0.25 [/usr/lib/dotnet/shared/Microsoft.AspNetCore.App]
  Microsoft.NETCore.App 6.0.25 [/usr/lib/dotnet/shared/Microsoft.NETCore.App]

Link to comment
  • 0

Have tried changing VDA port, nothing...

I can telnet to the DDC from Ubuntu VDA using relevant port.

Tried different versions of dotnet. (seems like this install of Ubuntu VDA only accepts dotnet6, as described in documentation)

Did run Windows updates as well for what that is worth. (DDC and AD/DNS is on S2022)

Setup reverse lookup zones for DNS.

Created a CName for DDC. (not just A record) just to test.

Tried older install 2205 vs 2208, not working still same error.

Strange don't know what to troubleshoot futher.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...