Jump to content
Welcome to our new Citrix community!
  • 1

Missing PDCRYPT2.DDL in ARM64 packages


Mario Futire

Question

First of all, good job for the ARM 64 version. Really good to run Citrix on a PI400 with Raspi 64.

But there is a problem: the file PDCRYPT2.DLL is not shipped with the ARM 64 versions (deb and tar.gz).

 

Was it simply forgotten?

Could an updated version with this file be posted on the website.

 

The other issue is that the armhf version does not work well on a Raspi 64 bit version. Screen is not refreshed after the initial repaint. I think events are still passed to the remote, but local screen is not updated.

This is a fallback, the native 64 bit version would be the best solution.

 

Thank you

20230625_154651.jpg

Link to comment

6 answers to this question

Recommended Posts

  • 1

I know I sound as like a broken record, but the problem is still present in 2308.

 

Are these forums a waste of time? Does anyone in Citrix care a bit about all of this?

Making this work on a Pi 64 bit would be a great feature for Citrix.

 

Anyway, see you in a month for the next version.

  • Like 1
Link to comment
  • 0

This issue is still present in Citrix Workspace App for Linux 2309 arm64

 

I have raised a support case (#82364870) in an attempt to identify a fix.  

 

Edited to add:  The missing file is PDCRYPT2.DLL (OP misspelt this as PDCRYPT2.DDL on this thread's subject)

 

Edited by Stephen Bright
Clarification of missing file name
  • Like 1
Link to comment
  • 0
On 11/24/2023 at 8:04 AM, Stephen Bright said:

This issue is still present in Citrix Workspace App for Linux 2309 arm64

 

I have raised a support case (#82364870) in an attempt to identify a fix.  

 

Edited to add:  The missing file is PDCRYPT2.DLL (OP misspelt this as PDCRYPT2.DDL on this thread's subject)

 

 

After discussions and demonstrations of the issue with various versions of Linux and arm64 CWA, Citrix support have acknowledged the issue, but there is not currently a way to resolve this, as they have not yet developed the necessary arm64 crypto library.  To quote their support:

 

Quote

As discussed over the call, our product management team confirmed that the error "PDCRYPT2.DLL not found" is a technical limitation for ARM64 at this moment. Product managment team is implementing the secureICA 2.0 to mitigate the issue.

 

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...