Jump to content
Welcome to our new Citrix community!
  • 0

Citrix Workspace App "Add Account" does not work in Azure Virtual Desktop


Question

Currently working with a customer who needs to load Citrix Workspace into their Azure Virtual Desktop. Things that I know:

You can launch a session by going to the web and letting it detect workspace.

This only happens if the OS is specifically Windows 10 Enterprise for Virtual Desktops or Windows 11 Enterprise for Virtual Desktops.

It happens regardless of the Azure subscription (ie I've tried it on multiple VMs across multiple subscriptions).

You can add account using Citrix Workspace on Windows 10 or Windows 11 with no issues.

The installation is definitely different as it appears to install a lot slower.

I have tried different versions of Citrix Workspace and I also tried Citrix Receiver.

You can also add account in the Virtual Desktops if the Citrix environment is connected to Citrix Cloud ie customername.cloud.com versus citrix.somedomain.com.

The error is attached that appears across multiple subscriptions regardless of Windows 10 or Windows 11 Enterprise Virtual Desktops 21H2 or 22H2.

 

I have tried installing using /forceinstall. Doesn't matter if the VM is domain joined or not. These are fresh images straight from the marketplace.

 

Any ideas would be great before I put in a ticket with Citrix support.

 

2023-04-12 17_01_27-Window.jpg

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...