Jump to content
Welcome to our new Citrix community!
  • 0

Can you bypass vPrefer for a specific published app?


Derek Loveless

Question

I'm playing with vPrefer and trying to make sure I understand it in my lab.  I understand how it works generally, and it made me question a scenario that might come up.

Here's my potential scenario: A web app is using whitelisting to only allow connections from specific IP addresses.  Let's say the specific IP addresses are the few machines in Delivery Group A. 

 

As it stands, if I were to publish Edge pointed at web app URL, hosted from Delivery Group A, it would redirect to using my local Edge client, and the web app would fail to load.

 

Another, maybe more realistic scenario is limiting the install of Java to a few servers instead of all workstations.  If the webapp leverages Java, and you want to control costs, and have that single image/install to manage.  In either scenario, what would need to happen to allow that individual published application to launch on the server (aside from telling users to login to Storefront web ?)?  Is it possible?  One potential option I thought of was disabling vPrefer and using the old school KEYWORDS to use local apps, or just not using local apps at all (as we have done for years).

 

 

Citrix Cloud DaaS
Workspace app 2203 CU2

Storefront 1912 CU5

 

Thanks,

Derek

Edited by Derek Loveless
Added another scenario.
Link to comment

4 answers to this question

Recommended Posts

  • 0
18 hours ago, James Kindon said:

Maybe publish the app but restrict it to specific machines using tags?

 

Pretty sure vPrefer configurations override keywords - so might be a bit of work to change things around

I just tested this by setting my app group to target servers based on tags, exited Workspace app, and launched.  It still launched locally.  Thank you for the suggestion.

Link to comment
  • 0
6 hours ago, Jeff Riechers1709152667 said:

You can use powershell to set locallaunchdisabled to true.  I use that on web apps that require launch from a particular server with it's necessary plugins.

 

https://developer-docs.citrix.com/projects/citrix-virtual-apps-desktops-sdk/en/latest/Broker/Set-BrokerApplication/

 

This is the answer!  I set it to true, refreshed my apps, and it didn't open locally.  Thank you.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...