Jump to content
Welcome to our new Citrix community!
  • 0

Workspace App latest for Linux : Cannot connect to 0.0.0.2 - only when using Mobile Phone Tethering/AccessPoint ( wifi/USB/Bluetooth )


yan mer

Question

Issue:

Workspace App latest for Linux : ( Error popup when clicking the app in the portal )

 

Cannot connect to "0.0.0.2 - AppName" :

Address family not supported by protocol. Verify your connection settings and try again.

=Quit=

 

Happening 

only when using Mobile Phone Data connection ( 3g/4g/LTE) Tethering/AccessPoint ( wifi/USB/Bluetooth )

 

Tried known workarounds :

ProxyUseFQDN=Off is already off

I reverted back to 13.8

 

Also tried this from the solutions online : ( but I didnt expect it to work, since it works when Linux OS has internet connectivity through normal ISP wifi/ethernet )

replaced /opt/Citrix/ICAClient/keystore/cacerts

by a symlink to : /etc/ssl/certs

also trieed a symlink to : /usr/share/ca-certificates/mozilla

 

both didnt worked, also those target directories were populated with certificates

 

 

Please let me know if you have a fix for this issue, or how we can proceed to diagnose it further

Link to comment

4 answers to this question

Recommended Posts

  • 0

I tested with

- two different laptop dell and lenovo

- three different OS Windows 10 , Linux Mint, Android

- many different internet connections, ISP Wifi, ISP wired, 4g mobile Tethering USB/Bluetooth/Wifi AP

 

The only combination showing the issue is Linux + mobile Tethering

I suspect the Citrix Client for Linux having an issue, since all the rest of internet connectivity is working fine on linux + mobile tethering

 

I want to take this to Citrix Tech support, how could I contact the right support technical group for Linux version of the Workspace App ?

Link to comment
  • 0

The bug seems to affect Citrix Portal / Citrix Workspace App Client under Linux ONLY when Mobile Phone's APN is IPv6

When I force it back to IPv4, its working

 

Yesterday I tested with 3 other mobiles iphones and android, none of them exhibited the issue ( they were APN IPv4 only )

 

- This issue does not manifest under Windows10 or Android ( even when APN is IPv6 )

- All other Linux network communication works fine, only citrix client/portal is affected ( While APN is IPv6 )

 

To reproduce the issue :

With Linux, connect to the internet through a Mobile with IPv6 on the APN, confirm the mobile obtains a IPv6 address in "Mobile Network Diagnostics" screen

Reload the Citrix portal, and click to download/launch  the .ica

 

Citrix Support, can you bring this issue to Dev team to have them fix the Linux Client so that it will work like the WIndows/Android one

even when there is IPv6 used upstream in between it and the portal ?

 

thanks !

Screenshot_2023-03-15-11-15-30-212_com.android.settings.jpg

Screenshot_2023-03-15-11-15-42-559_com.android.phone.jpg

Screenshot_2023-03-15-11-14-01-625_com.android.settings.jpg

Screenshot_2023-03-15-11-14-42-137_com.android.phone.jpg

Screenshot_2023-03-15-09-08-47-412_com.android.settings.jpg

Screenshot_2023-03-15-09-09-13-838_com.android.phone.jpg

Screenshot_2023-03-15-11-15-03-449_com.android.settings.jpg

Link to comment
  • 0

I found the problem is fixed when I disable IPv6 on Linux OS

Then, it doesnt matter if it is used on the AP, it wont use it

Two ways to disable it, with sysctl or this :

nmcli con mod 95b13bee-9ebd-442e-8eb3-66a8816f6535 ipv6.method disabled

nmcli con 95b13bee-9ebd-442e-8eb3-66a8816f6535 up

 

route -6 will then not show this route for IPv6

[::]/0                         _gateway                   UG   600 9     0 wlp2s0

this confirms IPv6 will not be used

 

I can confirm tested this on Windows with IPv6 routing enabled, it works

 

Why IPv6 support not yet working in Linux for citrix ?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...