Jump to content
Welcome to our new Citrix community!
  • 0

Windows 2019 Server VDAs Start Menu and Taskbar missing File Explorer


John Keiling

Question

When users login to our Windows 2019 Server VDAs File Explorer does not get pinned to the taskbar. When searching for "File Explorer" nothing is found but if you search for explorer.exe it will launch. 

In addition, the control panel icon has a place holder called W~Microsoft.Windows.ControlPanel. Randomly when a user logs in the File Explorer will be pinned normally but 99% of the time it is missing. 

Has anyone seen this before?
I attached a screenshot below.

 

no-file-explorer.jpg

Link to comment

10 answers to this question

Recommended Posts

  • 0
2 hours ago, Carl Stalhood1709151912 said:

Hi Carl I just tried your recommendation, the layout does change according to the new default in LayoutModification.xml but as you can see in the screenshot File Explorer still doesn't show up in the start menu or taskbar. Every other change I made is carried over to the new logins. 

start-menu-no-explorer-2.jpg

Link to comment
  • 0
58 minutes ago, Darryl Sakach said:

Do you use a roaming profile manager like Citrix UPM or FSLogix in your environment? This can happen when you share a profile amongst different OS versions or even the same OS version with different configs.

We use Citrix UPM, all the VDAs are Windows Server 2019

Link to comment
  • 0
14 minutes ago, Carl Stalhood1709151912 said:

Have you tried it as a user with a no profile (delete the old profile to act like a new user)?

I tried a few things, all didn’t work:

- deleted the user profile on the server

- tried multiple Server 2019 VDAs

- removed the UPM profile

- removed the UPM policy

- the only thing that gets it to work is to remove the VDA completely, reboot, and use straight RDP to the server with a new profile. As soon as the VDA is on the server this issue occurs. It even occurs with RDP at that point.

- upgraded to 2203 CU2, didn’t work

- tried a fresh Server 2019 install

Something with the interaction with the VDA / Windows Server OS must be causing this. 
 

Link to comment
  • 0

Edit your layout modification XML on the default profile, make sure that all the shortcuts go to all users, not to a local user location.

 

Also if you set it as the layout modification in the default profile it will only pertain to new users.

 

If you want it to be non-editable you can put it on a file share and hard point all users with gpo to it.

Link to comment
  • 0
14 hours ago, Carl Stalhood1709151912 said:

Pinned items are under C:\Users\admin\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar. Are your roaming profiles configured to save this path at logoff?

Carl, you pointed me in the right direction.  The VDAs have a GPO that configures folder redirection for users. One of the folders that was redirected was AppData Roaming. I removed this policy setting from the GPO, deleted the user's profile, and everything works normal now, including the layout modifications. If you can provide some insight as to why redirecting AppData would cause this I would appreciate it. I still have in place a Citrix Profile policy that stores some AppData folders in the UPM. Thanks!

appdata-roaming.jpg

appdata-citrix-policy.jpg

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...