Jump to content
Welcome to our new Citrix community!
  • 0

Ubuntu 18.04 VDI - MCS catalogue Creation Errors

Chris Hibbert


Hoping someone might be able to point me in the right direction.


I've been trying to present an Ubuntu 18.04.02 master gold image to create a MCS machine catalogue, however it fails to add any machines to the catalogue, I'm getting the same error each time after I make slight changes, however nothing I change will enable this to complete.


I did originally get a different error about suitability but I've not been able to replicate that again. The error is:



Transaction ID: 4800846b-76ef-446c-b361-457ba2cd0532
Action Name: CreateMachineCatalog

    DesktopStudio_ErrorId : ProvisioningTaskError
    ErrorCategory : NotSpecified
    ErrorID : ImagePreparationFinalizationFailedCompletely
    TaskErrorInformation : Terminated
    InternalErrorMessage : No Image Preparation results found. There may be no suitable VDA installed, or some other serious failure in the Master VM. Image preparation failed.
    DesktopStudio_PowerShellHistory : Create Machine Catalog 'XXXX-XXXXXX'
    7/13/2022 1:40:10 PM
    Get-LogSite  -AdminAddress "localhost:19097" -BearerToken ********
    Start-LogHighLevelOperation  -AdminAddress "localhost:19097" -BearerToken ******** -Source "Studio" -StartTime "7/13/2022 1:40:10 PM" -Text "Create Machine Catalog `'GXXXX-XXXXXXx`'"
    New-BrokerCatalog  -AdminAddress "localhost:19097" -AllocationType "Permanent" -BearerToken ******** -IsRemotePC $False -LoggingId "71a15922-bb3c-4aa7-8baa-a08b41206679" -MinimumFunctionalLevel "L7_20" -Name "XXXX-XXXXXXx" -PersistUserChanges "OnLocal" -ProvisioningType "MCS" -Scope @() -SessionSupport "SingleSession" -ZoneUid "6911f74d-eb08-42ff-9357-64723564ca64"
    New-AcctIdentityPool  -AdminAddress "localhost:19097" -AllowUnicode -BearerToken ******** -DeviceManagementType "None" -Domain "xx.yy.zzz.com" -IdentityPoolName "GXXXX-XXXXXXx" -IdentityType "ActiveDirectory" -LoggingId "71a15922-bb3c-4aa7-8baa-a08b41206679" -NamingScheme "xxx.xxx.xxxxx" -NamingSchemeType "Alphabetic" -OU "OU=BLAH,OU=CitrixVDI,OU=Base Windows Software Updates,DC=xx,DC=xx,DC=com" -Scope @() -StartCount 1 -ZoneUid "6911f74d-eb08-42ff-9357-64723564ca64"
    Set-BrokerCatalogMetadata  -AdminAddress "localhost:19097" -BearerToken ******** -CatalogId 163 -LoggingId "71a15922-bb3c-4aa7-8baa-a08b41206679" -Name "Citrix_DesktopStudio_IdentityPoolUid" -Value "1af784fb-4ef3-48e7-a7ea-9c2b5dffc93d"
    Test-ProvSchemeNameAvailable  -AdminAddress "localhost:19097" -BearerToken ******** -ProvisioningSchemeName @("XXXX-XXXXXXx")
    New-ProvScheme  -AdminAddress "localhost:19097" -BearerToken ******** -CustomProperties "<CustomProperties xmlns=`"http://schemas.citrix.com/2014/xd/machinecreation`">`r`n  <StringProperty Name=`"ContainerPath`" Value=`"/1453.storage`"/>`r`n  <StringProperty Name=`"vCPU`" Value=`"2`"/>`r`n  <StringProperty Name=`"RAM`" Value=`"8192`"/>`r`n  <StringProperty Name=`"CPUCores`" Value=`"4`"/>`r`n</CustomProperties>" -HostingUnitName "XXXX-XXXXXXy" -IdentityPoolName "xxx.xxx.xxxxx" -InitialBatchSizeHint 1 -LoggingId "71a15922-bb3c-4aa7-8baa-a08b41206679" -MasterImageVM "XDHyp:\HostingUnits\XXXX-XXXXXX\xxxxx-ubu18-master.0.3a.template" -Metadata @{"NutanixCoresPerCpu"="4";"NutanixContainerId"="1453"} -NetworkMapping @{"0"="XDHyp:\HostingUnits\XXXX-XXXXXXy\Desktops.network"} -ProvisioningSchemeName "xxx.xxx.xxxxxx" -RunAsynchronously -Scope @() -VMCpuCount 2 -VMMemoryMB 8192
    Remove-ProvTask  -AdminAddress "localhost:19097" -BearerToken ******** -LoggingId "71a15922-bb3c-4aa7-8baa-a08b41206679" -TaskId "7c14044e-62f6-49d0-80df-ef3ef9e8fc49"
    Error Source : CitrixOrchestration

There's some technical guidance available HERE for this error in a windows VDI (increasing the logging and where the logs are generated) but I cannot find anything similar for a linux VDA environment.


Is anyone aware how I might be able to increase logging within a ubuntu master image and where the log files route to?


Also I've tried finding any technical resources/guidance on creating the perfect Ubuntu (or any Linux) image for Citrix, does such guidance exist?


Thanks for any assitance




Link to comment

5 answers to this question

Recommended Posts

  • 1

A very common mistake is the preparation of the master image

Can you confirm that you did make the master image exactly as per suggested here ?




There are differences in the way Master image is created for Linux and Windows hence the suggestion 

  • Like 2
Link to comment
  • 0
On 7/21/2022 at 4:38 AM, Chris Hibbert said:

Hi @Boby John,


This has solved the catalogue creation so thanks a lot for the suggestion, I'd missed something failing on the deploymcs.sh - but now onto my next struggle a blank grey screen when connecting........


Thanks a gain.

Were you able to resolve the gray screen? I've been trying to troubleshoot it as well for the last few weeks.

Link to comment
  • 0
On 11/9/2022 at 11:32 PM, Viet Pham said:

Were you able to resolve the gray screen? I've been trying to troubleshoot it as well for the last few weeks.

Make sure you install ALL of the prereqs for the Linux VDA. No all of them are installed by simply following the MCS guide. Please look at the manual install part of the guide. We had the same, but it was fixed by installing all prereqs manually before running deploymcs.sh


I hope you guys already have fixed it ?



Best regards,


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...