Jump to content
Welcome to our new Citrix community!
  • 0

XenServer - XenCenter - VM console is NOT working but Xenserver console within XenCenter is

Piotr Ostrowski


Dear Community, 


need your advise, I tried the downgrade of XenServer from 8.2 LTSR to 7.1 LTSR.

* Have XenCenter 8 and 7

* this is windows context (I'm trying to install windows operating system on it) - so far did it sucessfully dozen of times and there were no issue with that

* I can see the console of XenServer within the XenCeter

* the console of the VM is blank (it's empty frame) , I just can not progress with regular windows OS installation (scaling does not change the situation, the frame become smaller or larger)

* due to the fact the network stack on the VM is no there and there is no operating system on it I can not access it over 3389, right

* the iso is exposed over the local storage repository (within the dom0) (sr type ISO) and this way I'm trying to have it consumed from the vm skel

* I'm having tremendous difficulties to map the SMB/CIFS over the share exposed via network - have been trying with the xencenter gui with the following option as username : [username],dom=[domain],vers=3.0 (tried it also with 2.0) -  no difference

* tried with the regular mount via ssh - no luck as well

* NTP is in sync (missing the stratum by 112ms)


* undocking redocking - does not help

* removing the appdata xencenter cache - did not help


any direction / advise highly appreciated

I know Xen is tricky from time to time, but common


I do have a citrix case opened, but so far got stuck

Link to comment

3 answers to this question

Recommended Posts

  • 0

Citrix is not too hip on downgrading. Is your XenCenter a 7.x version ?  You might just have to install XenServer fresh/clean

to get it working again right. VM's are backed up I take it? Can you migrate them to another server while doing maintenance

on this one ?




Link to comment
  • 0

Hi Alan,

thank you for the reply !

For the XenServer dowgrade I just gave some insight for the full story, never the less at the moment after fresh installation of the XS 7.1LTSR and regardless of the XenCenter version (I do have 7 and 8 on different endpoints) I just see blank screen for the virtual console. As I said the network stack of the VM is not there yet, so the button for switch to remote desktop does not exist, like it does when the Operating system is already installed.

This is happening on the fresh install of the xenserver, as I miserable very much with the downgrade. (will drop some detail to sum up the thread, once I get the reply about the HCL compatibility from the vendor for the XS8LTSR, then will drop some insight).


* my main issue is that I can not provision any new VM due to the lack of visibility of that virtual console which allows me installing the OS.

* forget for a while about the previous VDI's, storage etc..

Link to comment
  • 0

did the test of the iso on another server, by introducing the local iso repository, it was just working like a charm, so decided to reinstall the host from a scratch.

It helped, now the virtual console for the VM's is back operational, both on the device where the XenCenter 7 is, and on the one where XenCenter 8 is in place.

Thread can be closed. Thank you for your help !

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...