Jump to content
Welcome to our new Citrix community!
  • 0

Linux Host / Teams on Windows client does not detect microphone

Thorsten Niehues


Skype for Business is able to do Calls / it detects the microphone


Teams however does not detect the microphone so I can not join any meetings..


How to fix this??



  • Linux Host : Ubuntu 20.04.3
  • Citrix Workplace 21.12 (newest)
  • HDX 2.9


I tried / made sure so far

  • Tried upgrading from Citrix Workplace 21.03 to 21.12 (newest version as of Jan 18 2022)
    -> This resulted in complete loss of HDX connection -  audio was completely gone (Skype for Business & Teams)
  • After remove and install HDX via install script (did not uninstall via apt) Skype for business detects the headset again (mic and speaker again -> can to calls)
    Teams however is still unable to detect the microphone
  • I also made sure the the software is installed https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html
Link to comment

1 answer to this question

Recommended Posts

  • 0

I could fix detecting audio devices in Microsoft Teams by installing libc++1-12 and libunwind-12 on the local linux / ubuntu 20.04 host :


curl -fsSL https://apt.llvm.org/llvm-snapshot.gpg.key | sudo apt-key add

sudo add-apt-repository "deb http://apt.llvm.org/focal/ llvm-toolchain-focal-12 main"

sudo apt-get update

sudo apt-get install libc++1-12 libunwind-12


Also anwered on https://superuser.com/questions/1701011/citrix-linux-host-win-client-microsoft-team-does-not-detect-audio-devices

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...