Jump to content
Welcome to our new Citrix community!
  • 0

update kernel 5.15,boot stopped on "Timed out waiting for device dev-mapper-rl\x2dswap.device"

yc lee


A new RockyLinux8.5(CentOS8.5) VM is installed on XenServer8.2 host. There is no problem with the 4.18 kernel. After upgrading to the latest 5.15 kernel, the boot fails "dracut Warning: /dev/mapper/rl-root does not exsit"


show error "Timed out waiting for device dev-mapper-rl\x2dswap.device"

After checking, I feel that the disk cannot be found when starting up Boot is a separate partition, the root partition and swap partition are both on the lvm partition I add "xen_emul_unplug=never" to /boot/grub2/grub.cfg ,the VM can boot success.

After installing xe-guest-utilities, vio and vif drivers do not take effect.

Are there any special options in the kernel after 5.13 that affect the virtual machine of the xen platform?

Link to comment

2 answers to this question

Recommended Posts

  • 0

I have solved this problems by self.

I recompiled the 5.15 kernel, and found that in the default compilation configuration, "Xen Virtual Block Device Support" and "Xen Block Device Backend Driver" are compiled in module (M) mode, I changed it to built-in mode (*) to compile, all the problems are solved. The VM can be started without adding the "xen_emul_unplug=never" parameter, and the VM-guest-tools status is also normal.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...