Jump to content
Welcome to our new Citrix community!
  • 0

Citrix ica file not found on Ubuntu docker image [UPDATED]


Emerson Soares

Question

I have a Ubuntu docker image with chrome and Citrix Workspace for Linux Version 21.11.0.20 and I am getting the File not found message when trying to open the file, but the file exists in the /home/emerson/Downloads folder.

I have granted 777 access to the /home/emerson/Downloads folder:
$ ls -l /home/emerson/
total 0
drwxrwxrwx 1 emerson users 0 Nov 12 13:04 Downloads

 

These errors messages below are those that took more my attention:
citrix-wfica[1205]: VDEUEM: Insufficient Input buffer size: 0 bytes. Required buffer size: 48 bytes
citrix-wfica[1205]: VDEUEM: DriverInfo failed. rc = 0x3ec
citrix-wfica[1205]: VDMM: Insufficient Input buffer size: 0 bytes. Required buffer size: 50 bytes
citrix-wfica[1205]: VDMM: DriverInfo failed. rc = 0x3ec

 

I have added the below attributes to the file /etc/icaclient/nls/en/module.ini
BufferLength=2048
BufferLength2=5000
MaxRequestSize2=4116
MaxWindowSize2=62500

 

[UPDATE] The error [1:40:1112/132632.684680:ERROR:bus.cc(392)] Failed to connect to the bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory was fixed after install dbus and start it in the same script I am starting Google Chrome, but the "File not found" issue persists.

 

Find below the consolidate output:

# Starting Google Chrome:
[1736:1767:1117/185507.896352:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[1777:1777:1117/185507.952548:ERROR:angle_platform_impl.cc(44)] Display.cpp:894 (initialize): ANGLE Display::initialize error 12289: Could not create a backing OpenGL context.
[1777:1777:1117/185507.952758:ERROR:gl_surface_egl.cc(782)] EGL Driver message (Critical) eglInitialize: Could not create a backing OpenGL context.
[1777:1777:1117/185507.952836:ERROR:gl_surface_egl.cc(1382)] eglInitialize OpenGL failed with error EGL_NOT_INITIALIZED
[1777:1777:1117/185507.953666:ERROR:gl_ozone_egl.cc(20)] GLSurfaceEGL::InitializeOneOff failed.
[1777:1777:1117/185507.955247:ERROR:viz_main_impl.cc(161)] Exiting GPU process due to errors during initialization
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[1951:1951:1117/185508.118178:ERROR:sandbox_linux.cc(376)] InitializeSandbox() called with multiple threads in process gpu-process.
[1823:7:1117/185508.122267:ERROR:command_buffer_proxy_impl.cc(125)] ContextResult::kTransientFailure: Failed to send GpuControl.CreateCommandBuffer.
[1736:1762:1117/185512.201698:ERROR:chrome_browser_main_extra_parts_metrics.cc(226)] crbug.com/1216328: Checking Bluetooth availability started. Please report if there is no report that this ends.
[1736:1762:1117/185512.201714:ERROR:chrome_browser_main_extra_parts_metrics.cc(229)] crbug.com/1216328: Checking Bluetooth availability ended.
[1736:1762:1117/185512.201720:ERROR:chrome_browser_main_extra_parts_metrics.cc(232)] crbug.com/1216328: Checking default browser status started. Please report if there is no report that this ends.
[1736:1762:1117/185512.289054:ERROR:chrome_browser_main_extra_parts_metrics.cc(236)] crbug.com/1216328: Checking default browser status ended.

#-------------- connecting to mydesk

#-------------- connecting to remote host

#-------------- opening ica file
citrix-wfica[2205]: Failed to connect with logd.
citrix-wfica[2205]: Value of cl_argv[0] : /opt/Citrix/ICAClient/wfica
citrix-wfica[2205]: Value of cl_argv[1] : -icaroot
citrix-wfica[2205]: Value of cl_argv[2] : /opt/Citrix/ICAClient
citrix-wfica[2205]: Value of cl_argv[3] : /home/emerson/Downloads/launchExtMSAD.ica
citrix-wfica[2205]: ReadINIConfig() exiting
citrix-wfica[2205]: Called NCSXMLanguageInit: language is C locale, codepage is 1252

citrix-wfica[2206]: Value of cl_argv[0] : /opt/Citrix/ICAClient/wfica
citrix-wfica[2206]: Value of cl_argv[1] : -version
citrix-wfica[2205]: Can't create serial number file '/etc/icalicense/clientlicense' - 'File exists'
citrix-wfica[2205]: New serial number file ?? made by another client
citrix-wfica[2205]: VDSCARD: DriverOpen failed. rc = 0x405
citrix-wfica[2205]: WSTCP:resolve name ;40;STA238587011;955E4F7E6E44DF9A12E0D456399222
citrix-wfica[2205]: Cgp_SetCLSessionContext pSC is null
citrix-wfica[2205]: doEncryptData inbuffersize: 175
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 229
citrix-wfica[2205]: doEncryptData inbuffersize: 31
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 85
citrix-wfica[2205]: doEncryptData inbuffersize: 9
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 53
citrix-wfica[2205]: VDEUEM: Insufficient Input buffer size: 0 bytes. Required buffer size: 48 bytes
citrix-wfica[2205]: VDEUEM: DriverInfo failed. rc = 0x3ec
citrix-wfica[2205]: VDMM: Insufficient Input buffer size: 0 bytes. Required buffer size: 50 bytes
citrix-wfica[2205]: VDMM: DriverInfo failed. rc = 0x3ec
citrix-wfica[2205]: doEncryptData inbuffersize: 1457
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 1509
citrix-wfica[2205]: doEncryptData inbuffersize: 1173
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 1221
citrix-wfica[2205]: doEncryptData inbuffersize: 6
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 53
citrix-wfica[2205]: doEncryptData inbuffersize: 8
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 53
citrix-wfica[2205]: doEncryptData inbuffersize: 181
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 229
citrix-wfica[2205]: SSL session strength: 128
Anomaly in MIT_SHM attach: 1 attachments, perm 1600.
citrix-wfica[2205]: doEncryptData inbuffersize: 13
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 69
citrix-wfica[2205]: doEncryptData inbuffersize: 5
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 53
citrix-wfica[2205]: doEncryptData inbuffersize: 5
citrix-wfica[2205]: SSLPutDataFn inbuffersize: 53
citrix-wfica[2205]: Not connected
citrix-wfica[2205]: DriverClose: deallocate the data buffers device: 1
citrix-wfica[2205]: VDEUEM: DriverClose failed. rc = 0x3fe
citrix-wfica[2238]: Value of cl_argv[0] : /opt/Citrix/ICAClient/wfica
citrix-wfica[2238]: Value of cl_argv[1] : -eula
citrix-wfica[2238]: Value of cl_argv[2] : -tell
citrix-wfica[2238]: Value of cl_argv[3] : MinimumTLS,MaximumTLS,SSLCiphers
citrix-wfica[2238]: ReadINIConfig() exiting
Error: no such file "/home/emerson/Downloads/launchExtMSAD.ica"
Opening "/home/emerson/Downloads/launchExtMSAD.ica" with Citrix Workspace Engine  (application/x-ica)
citrix-wfica[2245]: Failed to connect with logd.
citrix-wfica[2245]: Value of cl_argv[0] : /opt/Citrix/ICAClient/wfica
citrix-wfica[2245]: Value of cl_argv[1] : -icaroot
citrix-wfica[2245]: Value of cl_argv[2] : /opt/Citrix/ICAClient
citrix-wfica[2245]: Value of cl_argv[3] : /home/emerson/Downloads/launchExtMSAD.ica

#---------------- File not found pop-up message
citrix-wfica[2245]: WD not loaded
citrix-wfica[2245]: WD not loaded
[2313:2344:1117/185745.942920:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
[2313:2344:1117/185745.942956:ERROR:bus.cc(393)] Failed to connect to the bus: Could not parse server address: Unknown address type (examples of valid types are "tcp" and on UNIX "unix")
Opening in existing browser session.
Fontconfig error: Cannot load default config file: No such file: (null)
[1736:1736:1117/185745.987783:ERROR:interface_endpoint_client.cc(658)] Message 0 rejected by interface blink.mojom.WidgetHost
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
[2353:2353:0100/000000.014428:ERROR:angle_platform_impl.cc(44)] Display.cpp:894 (initialize): ANGLE Display::initialize error 12289: Could not create a backing OpenGL context.
[2353:2353:0100/000000.014497:ERROR:gl_surface_egl.cc(782)] EGL Driver message (Critical) eglInitialize: Could not create a backing OpenGL context.
[2353:2353:0100/000000.014517:ERROR:gl_surface_egl.cc(1382)] eglInitialize OpenGL failed with error EGL_NOT_INITIALIZED, trying next display type
[2353:2353:0100/000000.015084:ERROR:angle_platform_impl.cc(44)] Display.cpp:894 (initialize): ANGLE Display::initialize error 12289: Could not create a backing OpenGL context.
[2353:2353:0100/000000.015128:ERROR:gl_surface_egl.cc(782)] EGL Driver message (Critical) eglInitialize: Could not create a backing OpenGL context.
[2353:2353:0100/000000.015157:ERROR:gl_surface_egl.cc(1382)] eglInitialize OpenGLES failed with error EGL_NOT_INITIALIZED
[2353:2353:0100/000000.015181:ERROR:gl_ozone_egl.cc(20)] GLSurfaceEGL::InitializeOneOff failed.
# ------------- Closing chrome

Does someone have some help to share?

Thank you.

IcaFileNotFount.png

Link to comment

2 answers to this question

Recommended Posts

  • 0

Seems like you posted on the LinuxVDA forum Instead of Citrix WorkSpace App for Linux forum.

 

Assuming that your docker image has a GUI - if it does not , I dont think it would work.


1. Looks like you renamed the ICA file after download ? What if you try without renaming ?

2. There is a CLI Way to launch ICA which is , is the path autofilling when you type it ? 

/opt/Citrix/ICAClient/wfica <path-to-ica> 

3. And have you exported your Downloads folder as a Webpage as well ?  

4. Also just to ensure that all pre-reqs are taken care , try to run /opt/Citrix/ICAClient/util/workspacecheck.sh and see what comes in "red" 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...