Jump to content
Welcome to our new Citrix community!
  • 1

Citrix Workspace .ica Launch Error - System.MissingMethod Exception for Citrix.DesktopViewer?

Qasim Iqbal


After installing the latest Citrix Workspace update (2109), I was unable to remotely access my computer (attempting to launch the ica file resulted in nothing happening), and for some reason any attempt at uninstalling the Workspace software so I could reinstall it was made impossible, even after repeated restarts. After an extended period of deleting Citrix keys using regedit (following the advice of a help thread published by Citrix), I was finally able to uninstall and reinstall Citrix Workspace, but I'm now met with the below System.MissingMethodException error regarding the Citrix.DesktopViewer.


Does anyone know how to fix this issue? I've tried using the Receiver Cleanup utility and uninstalling/reinstalling Workspace a few times, but nothing has worked. I'm in dire need of help, as I need to use Workspace to access my work computer.



Link to comment

4 answers to this question

Recommended Posts

  • 0

Since the Upgrade to 2112.1 I do have the exactly same error. I have no idea what version I installed before, but I tried several older ones (including the suggested 2106) and also the newest 2202: Same error. On my laptop, I still can work with it, so I prevent any upgrades there, but can be sure it has noting to do with my citrix account itself.

It is probably a Windows Upgrade... What I can see that I still have 97.x Version of Edge and Edge WebView on my Laptop, on my PC with the error 98.x. 


At least I can exclude Nvidia Driver, cause I deinstalled that completely.

Both, Laptop and PC are AMD Ryzen based. 

The error occurs also with a completely new generated user, so it has nothing to to with the user profile or registry entry of this user.

Also the error occurs only when I start a desktop, not a published app (that one is working, as well as the Desktop in Citrix light inside the browser).


No idea what else I could try... 

Link to comment
  • 0
On 2/17/2022 at 12:14 AM, Kade Clifton said:

Uninstall Citrix Workspace using Revo uninstaller. Make sure to remove everything from the registry as well as the files. I use the advanced scan option. 
You can also fix this issue but manually extracting the missing file from the .exe 


THANK YOU SO MUCH!!! I used "Bulk Crap Uninstaller v5.2" (opensource), but also with this one it worked: Uninstall with BC uninstaller, installed again via CitrixWorkspaceApp.exe double-klick: Everything fine again!


Before, I tried several times uninstall / restart / install trials in the "usual" way, without any success. Also, I tried the remover Tool from Citrix. Seems like the Uninstaller from Citrix has some issues. 


Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...