Jump to content
Welcome to our new Citrix community!
  • 0

Issues with latest Guest Tools installer

Pete Wason


I've recently upgraded my (free edition) hypervisor and am trying to install Guest Tools (9.1.5) on a Win 10 VM.
I run managementagentx64.msi, it finishes, and wants a restart. I restart. It wants another restart. I restart.

(Sometimes, when I click Yes in the "needs a restart" dialog, it doesn't restart, so I do it from the start menu.)

It restarts, and wants another restart. No PV devices show up in device manager other than the following, under System Devices (i.e., not under Drives, Networking, etc.):


XenServer Interface
XenServer PV Bus
XenServer PV Bus (0001) [not hidden]
XenServer PV Network Class


It never seems to finish the install. Just keeps asking to restart.

Am I doing something wrong? Missing a step?

Link to comment

17 answers to this question

Recommended Posts

  • 1

Which log(s)? Application logs show "Cannot fix XenIface WMI interface" a few times.


Well, it just restarted and didn't ask again. So I shut it down and rebooted the VM, and it's asking to restart again. No change in device manage, or in XenCenter showing tools not installed, etc. I may give up on this latest version and drop back to the older 7.x version.

  • Like 1
Link to comment
  • 0

All I see (described above) in device manager is related to the version I'm tying to install.
I've tried an older version on Server 2019. P&F shows "7.1.1270 Citrix Xenserver Windows Management Agent", but XenCenter says "I/O not optimized / Management Agent not installed". And when I try to remove that old version, the uninstall fails claiming some process is using the files.
It's too bad the installers don't clean up/remove older versions or leftovers. Really gives the whole process a rather messy and unprofessional feel.

Link to comment
  • 0

There's no exporting/importing involved; I'm just trying to install the stuff.


Still wants to restart, but when I click Yes, it doesn't. TaskMgr shows XenSource Windows Guest Agent, XenService, and XENBUS_MONITOR all running. Restarting manually.


(Oddly, even though a "Citrix VM Tools Setup" dialog is opening every time I log on, taskmg doesn't show anything with that name running. Would that be installagent.exe?)

Link to comment
  • 0

I am also having the same issue and i think i did a mistake to uninstall the old management agent as mentioned here.


Known issues | Citrix Hypervisor 8.2


On a Windows VM, after you have installed the version 9.x Citrix VM Tools for Windows, you might see both the previous and the latest version of the tools or management agent listed in your Installed Programs:

(PREVIOUS) Citrix XenServer Windows Management Agent

(LATEST) Citrix Hypervisor PV Tools

The previous version of the management agent is not active and does not interfere with the operation of the latest version. We advise that you do not manually uninstall Citrix XenServer Windows Management Agent because this can disable the xenbus driver and cause the VM to revert to emulated devices.

Link to comment
  • 0

Still trying to hack this thing!

I have two server 2019 VMs (one core) which refuse to behave no matter which tools package I try. It's very frustrating. Either they just keep asking to restart (and not restarting on their own), or they say everything's OK and it isn't. I've tried Citrix tools from 7.x to 9.x, and XCP tools 8.x.


If this situation persists, I'll just retire. ha

Link to comment
  • 0

Finally tried the xtbugtool thingy. Right at the end of the script there's an "unspecified error". It creates an empty zip file.




Just removed 9.1.5, which apparently never finished installing. I logged off and back on as another user, and the "needs to restart" dialog didn't show up, but Center still shows no agent or drivers installed. Now trying 9.2.2.


Used cleaner before install, nothing found. After install and the first "needs restart" dialog, the VM just showed a black screen, and I couldn't log on. Looking at the CPU performance graph, I see the attached, some pretty.. weird CPU activity. Forced a restart, and was able to log on. Immediately got the "needs restart" dialog. ?


Edited by Pete Wason
more info
Link to comment
  • 0

I was having the same issue with 8.2.3. I noticed that the NIC IP was unknown and when looking in device manager there was a warning against the network adapter. I shutdown the VM, added a new NIC and powered the VM back up. I noticed that the new NIC was getting an IP but the original was still showing as unknown. I shutdown the VM again and then deleted the original NIC which was showing the unknown IP, powered up the VM and that seemed to fix it.


You may want to try uninstalling and re-installing XenServer Tools at this point just to keep it clean. Hope this helps



Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...