Jump to content
Welcome to our new Citrix community!
  • 0

[SOLVED] SSL Error 61: You have not chosen to trust "Entrust Root Certification Authority - G2", the issuer of the server's security certificate


Tomas Jedno

Question

Hi there,

 

I have a problem with the connection via Citrix. I'm trying to connect to the our application, but I'm getting this error:
image.thumb.png.49cb4ea6844c7f2b8a8835db64a79ec8.png

 

When I'm looking for the cert in certmgr, I found it in Trusted Root Certification Authority -> Cetrificates

image.thumb.png.83fc04900e774712a7db46f06f24109c.png

 

The Citrix Workspace version is 21.02.0.25 (2102) and Windows 10 build 19042.789. I was trying to uninstall Citrix and perform a new installation. I also tried the LTS version of Citrix Workspace. I also tried downloading the certificate from www.entrust.com and importing it. If I download Citrix to a private PC, the application works fine. Any idea how to fix this issue?

Link to comment

12 answers to this question

Recommended Posts

  • 0

@Martin: The problem is on my home network, at work and when connected via LTE modem. I tried to turn off the antivirus and firewall, but the problem keeps recurring.

 

@Sam: Could you please be more specific? Because the same version of the system, the same Citrix application, the same way of connecting, but on two devices different result (on one work, on the other not). Citrix on Android also works without problems

Link to comment
  • 0

I agree with @sam 

 

Also please update the root cert in case 

md C:\temp\certs

# download latest SST from Microsoft
CertUtil –generateSSTFromWU C:\temp\certs\RootStore.sst

# Import RootStore.sst to Trusted Root CA Store
$file=Get-ChildItem -Path C:\temp\certs\Rootstore.sst
$file | Import-Certificate -CertStoreLocation Cert:\LocalMachine\Root\

 

Thanks

Manoj

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...