Jump to content
Welcome to our new Citrix community!
  • 0

"Your sign on has expired. Please sign on again to continue" - When open the SecureHub Store


Question

Hello everyone.

When opening the SecureHub Store, it shows the message "Your sign on has expired. Please sign on again to continue".

 

The configuration was done by NS wizard, I could confirm that the clientless domains are correct on "Gateway > Global Settings > Configure Domains for Clientless Access"

I checked the clientless policies that were referenced at this article: https://support.citrix.com/article/CTX208792.

And I checked that the domain alias is equally on both, Netscaler's LDAP and XenMobile's LDAP.

 

I got the logs from the server, and it seems the cause:

 

WARN | http-nio-18443-exec-5 | com.citrix.xms.store | csrf token=XXXXXXXXXXXX failed to check csrf token

INFO | http-nio-18443-exec-5 | com.citrix.xms.store | filter.CsrfRequest - failed to validate csrf for this request, return 403

 

Server version: 10.13.0.11

NS version: tested on 12.1.57 and 12.1.60

 

Any thought are welcome.

Link to comment

2 answers to this question

Recommended Posts

  • 0
On 11/25/2020 at 10:31 PM, Alessandro Miotto Marques1709152314 said:

Hello everyone.

When opening the SecureHub Store, it shows the message "Your sign on has expired. Please sign on again to continue".

 

The configuration was done by NS wizard, I could confirm that the clientless domains are correct on "Gateway > Global Settings > Configure Domains for Clientless Access"

I checked the clientless policies that were referenced at this article: https://support.citrix.com/article/CTX208792.

And I checked that the domain alias is equally on both, Netscaler's LDAP and XenMobile's LDAP.

 

I got the logs from the server, and it seems the cause:

 

WARN | http-nio-18443-exec-5 | com.citrix.xms.store | csrf token=XXXXXXXXXXXX failed to check csrf token

INFO | http-nio-18443-exec-5 | com.citrix.xms.store | filter.CsrfRequest - failed to validate csrf for this request, return 403

 

Server version: 10.13.0.11

NS version: tested on 12.1.57 and 12.1.60

 

Any thought are welcome.

 

We had the same issue described here on a on-Prem installation.

see solution in the attachment. Best regards

 

CLI:

#Netscaler config: the index number must be free, check what entries are free and take the next free index number

bind policy patset ns_cvpn_default_inet_domains FQDN-OF-MDM:8443 -index 10

solution - failed to check csrf token - error 403.pdf

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...