Jump to content
Welcome to our new Citrix community!
  • 0

Select which kernel a VM should boot

Andre Ferreira



I´m having a problem to set which kernel a VM should boot.

In my case, I have a Debian install running kernel linux-image-4.19.0-9-amd64. For reasons, I want it boot with kernel linux-image-4.19.0-6-amd64, which is also installed. I've followed various manuals/tutorials/instructions in the web, but nothing worked. Grub simply does not appear and the current kernel always is the one booted.

I believe that in the paravirtualization, Xen and Debian are exchanging information that make this kernel the one to be booted. The Grub menu never shows, no matter what I try.

Now, is it really due to the paravirtualization? How do I select the kernel in a PV VM? Could somebody point me to a document with this information?





Link to comment

5 answers to this question

Recommended Posts

  • 0

As I've mentioned in my explanation, I've followed various guides trying to make the menu appear or set a specific kernel. The one you indicated was among of the first ones I tried, but nothing happened (no grub menu, and the default kernel loaded, ignoring the settings I tried).


In the mean time, I made a few more experiments and observations, and discovered something. All the VM's I have where the grub menu is working are HVM, and in all PV VM's, the menu does not appear. So, As a final test, I decided to convert a PV VM to HVM. I did this with the following commands in one of the Xen Servers:

xe vm-param-set uuid=<VM-UUID> HVM-boot-policy="BIOS order"

xe vm-param-set uuid=<VM-UUID> PV-bootloader=

xe vm-param-set uuid=<VM-UUID> PV-args=""

After this, I've set the bootable disk in properties/Boot options.


After this modification, the grub menu appeared as expected in the VM. So, what I suspected is now a certainty: In PV, the grub menu does not appear, in HVM it works fine. Does somebody now why this is happening, if this is expected and how do I modify this behavior?


Thank you,


Roberto Greiner


PS: My XenServers are running Xen 8.0 patched up to XS80E006

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...