Jump to content
Welcome to our new Citrix community!
  • 0

can't create export through CLI


Felix Rabinovich

Question

I have Citrix Hypervisor 8.2.0, and I am trying to create a backup of VMs through CLI:

xe vm-export uuid=41708186-... filename=/mnt/backup/dc2019.xva

However, I am getting the following error: 

Quote

There were no servers available to complete the specified operation.

 

I *am* on the server itself! so the message doesn't make any sense to me.

 

I tried -s localhost or -h localhost or with actual hostname. With -u and -pw and probably dozen other permutations. Also tried vm= instead of uuid. Same error.

I *am* able to take a backup from XenCenter; but I want to keep the backup on the server itself and not to move it over the network. I *was* able to do it in XenServer 7... 

Link to comment

5 answers to this question

Recommended Posts

  • 0

Yeah - in the hindsight it is stupid... I was staring at /dev/sdb instead of /dev/sdg and didn't realize that it was the internal Local Storage drive; rather than mounted backup drive. 

The gripe, I suppose, is that the error message was very misleading. How come there are no servers available, when I am running this command from the server itself! Even if it just told me that backup failed, I wouldn't chase the irrelevant problem :)

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...