Jump to content
Welcome to our new Citrix community!
  • 0

Citrix .ica file not opening in ububtu 20.04


Jawahir Junaith

Question

I have ubuntu 20.04. I installed citrix icaclient_20.04.0.21_amd64.deb in ubuntu. When i try to open the .ica file, I am getting the below error.

 

 

Cannot connect "0.0.0.2-VDI-W10-INTL"

Address family not supported by protocol. Verify your connection settings and try again.

 

I am trying from chrome and I am getting the same error when using firefox too.

 

 

 

Screenshot from 2020-07-03 15-06-55.png

Link to comment

5 answers to this question

Recommended Posts

  • 0

Hello,

 

Regarding this issue, could you take a look at the following thread: https://discussions.citrix.com/topic/323985-cannot-connect-to-0002-published-app-name-most-distros/?ct=1594039033

 

The second page of the thread references this URL (https://askubuntu.com/questions/901448/citrix-receiver-error-1000119) and a few folks seem to indicate that has addressed their issue.

 

Regards,

Jim G.

Link to comment
  • 0

Hi Jim,

 

Certificate rehashing and all the activities related to certificates, I have done. Still no luck.

 

Also, i tried different versions of linux receiver starting from 13.8 to the latest one. That also does not make any difference.

 

I tried to change the DNS as per the second page. I edited the resolve.conf to include that ip something like 8.8.8.8.4.4.4.4. Still no luck.

 

I am working in Ubuntu 20.04

Link to comment
  • 0

Yes, it would appear that the ica client only works for legacy ipv4, so this will fail on any system and connection from this century.

 

I would definitely not suggest disabling ipv6 on your entire system though, I'd prefer to configure the IPv4 address of your citrix server in /etc/hosts (or your resolver, should you have access to it).

 

But really, not supporting v6 should be considered bad these days, and failing on it completely without even falling back to v4 is simply a bug.

 

If you don't know the server name, you can run 'sudo tcpdump port 53' then start the client. It will fail, but it should show you the IPv4 and IPv6 addresses. Put the IPv4 address on a separate line in /etc/hosts, followed by the hostname that was queried. After that, it worked for me here.

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...