Jump to content
Welcome to our new Citrix community!
  • 0

Centos7 can't boot due lvm inactive volumes

Rafal Kowalski


I have a VM with Centos 7. It working fine until restarted it. After reboot, I saw dracut problem with disk avaiability.


I tried to run lvs - okay, lv are present. I've noticed that lvscan shows me that booth volumes are in inactive state


changed that tat to active by command

lvm vgchange -ay

exit, and exited from dracut and Centos boot as usual.


What I've tested:


- replace /boot form other (identical) machine)

- set to 0 use_lvmetad in lvm.conf

- set in dracut to add lvm driver

- after boot - dracut f and dracut --regenerate-all --force


Nothing help. Every time situation is the same.

How to repair a problem with unavailability of lv volumes during boot? 


in /etc/fstab nothing special - is the same as other VM's that works fine (of course, uuids  are different)

Tried to copy and change some data form working machines but every time a problem is with lvm.





Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...