Jump to content
Welcome to our new Citrix community!
  • 0

XS71 CU2 pool update hung


Philip John Gregg

Question

XS 7.1 CU2 installing 3 recent updates to a pool of two servers (rumi & hafez).

 

I auto-applied the three hotfixes to the pool. Rumi the master volunteered to go first. Patches were applied to rumi but when trying to migrate VMs back to hafez there was a storage error. The Xen Center options were "Retry" or "Finish". Retry went round the loop to same point so eventually Finish was chosen. I shutdown the offending VM and tried to apply the updates again. This time the slave node (hafez) was being updated.

 

After precchecks are done the following error occurs:

 

The following error occurred while automated updates were in progress: hafez: Internal error: /etc/xapi.d/extensions/pool_update.precheck

The automated updates process was not completed successfully. The update process has paused. Press Retry to resume it.

 

Retry has no effect. I tried applying updates one at a time but same error. Presumably rumi/hafez pool is in some wierd state and needs a slight adjustment or a bypass of the precheck script?

 

Many Thanks for reading.

 

Phil

 

 

 

 

 

 

 

Link to comment

6 answers to this question

Recommended Posts

  • 0

Thanks.

 

I tried applying the first of the patches to the slave manually using "xe patch-pool-apply uuid=00e49b0d..." which gave me more to work on:

 

XenAPI.Failure: ['SR_HAS_NO_PBDS', 'OpaqueRef:32cba639-dae6-a952-...] which sort of point me back to the original storage error issue.

 

Maybe I should reboot the slave and try again.

 

Anyone know how to work out the UUID from the OpaqueRef?

 

Cheers

 

 

 

 

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...