Jump to content
Welcome to our new Citrix community!
  • 1

iOS MDX wrapped app not able to open "Secure Web" URLScheme ctxmobilebrowsers


Dharani Karthhikeyan

Question

Dear Support Team,

 

We are developing iOS mobile business categorised application. In our app we perform oAuth login via "Secure Web" browser so from our app we launch "Secure Web" browser using url ctxmobilebrowsers://authservices-test.int.account.com/... which works fine (without MDX wrapping) but after MDX tool kit wrapping (Version 19.11.6 (2)), canOpenURL/openURL not launching "Secure Web" app. This is an important functionality of MDM not sure why its not working and i see many issue reported but not able to find right solution.

 

I also tried tried ^https:=ctxmobilebrowsers: based on citrix doc https://docs.citrix.com/en-us/mdx-toolkit/policies-platform/policies-ios.html and its not working because in our case we call with scheme ctxmobilebrowsers:// not https://

 

I attached the sample project which launches "Secure Web" without MDX wrapping. Please wrap with MDX tool kit and deploy to reproduce the issue.

 

Please help us to solve this issue and our customers are waiting for this fix. Currently Its a blocker for us.

 

Thanks, Vinoth

TestApp.zip

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...