Jump to content
Welcome to our new Citrix community!
  • 0

ShareFile 2FA enabled, Citrix CEM cant login anymore with service account.


Question

We have an on-premises XenMobile (CEM) environment. Now with 2FA enabled in Citrix ShareFile I cant connect from the XenMobile console to ShareFile with the "ShareFile Administrator Account"

 

It returns: username and password incorrect. 

 

Credentials are 100% correct as I can login on the sharefile website self (with 2fa). 

 

Do we need to disable 2fa on sharefile to get the XenMobile integration working again? 

 

 

Untitled.png

Link to comment

2 answers to this question

Recommended Posts

  • 0
1 hour ago, Jeroen Tielen1709158489 said:

We have an on-premises XenMobile (CEM) environment. Now with 2FA enabled in Citrix ShareFile I cant connect from the XenMobile console to ShareFile with the "ShareFile Administrator Account"

 

It returns: username and password incorrect. 

 

Credentials are 100% correct as I can login on the sharefile website self (with 2fa). 

 

Do we need to disable 2fa on sharefile to get the XenMobile integration working again? 

 

 

Untitled.png

 

Try creating an app specific password for XenMobile.  You can do that this way:

 

1. Login to Sharefile using the account that you have assigned for XenMobile using the cloud account for that ID

2. Select Settings > Personal Settings > Personal Security > Two Step Verification

3. Scroll down and to the App Specific Password section and click Create

4. Name and save the password to a document on your computer

5. Copy the password exactly as it is into the XenMobile configuration page (including any spaces)  and test the connection

 

Link to comment
  • 0
2 hours ago, David Wilkinson1709157632 said:

 

Try creating an app specific password for XenMobile.  You can do that this way:

 

1. Login to Sharefile using the account that you have assigned for XenMobile using the cloud account for that ID

2. Select Settings > Personal Settings > Personal Security > Two Step Verification

3. Scroll down and to the App Specific Password section and click Create

4. Name and save the password to a document on your computer

5. Copy the password exactly as it is into the XenMobile configuration page (including any spaces)  and test the connection

 


Hi David, thanks for the reply. This isn’t working. The password is only accepted if you uncheck “user account provisioning”. 
 

If I enable this feature the credentials are wrong. I think I need to create a support case/bug report. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...