Jump to content
  • 0

Error 193 when trying to install Citrix Workspace 1911 on windows 10 version 1909


Luís Amorim

Question

When trying to install Citrix Workspace 1911 on windows 10 version 1909 get error 193 I get the error indicating that the .Net Framework 4.6.2 or above is required.image.thumb.png.e609e8d7d0336795e8ae0c9b5c33b50c.png

 

On Windows 10 the .Net Framework is installed as a part of the features and I checked that this was active in features and available. On this version of Windows 10 the .Net Framework 4.8 i available.

I've tried inactivate the framework on features, reactivate it, reboot but every time I try to run the citrix installer, even has an administrator I get the error indicating the .Net Framework is required.

I even tried to install it as via installer but this is blocked by windows duw to a more recent framework being available through features.

 

I'm running out of ideas, can someone help with this issue?

 

Thanks in advance and regards.

 

 

Link to comment

9 answers to this question

Recommended Posts

  • 2

Hi guys,

 

Finnaly I've overcome this problem. After reading some post I was able to check the log from the failed installation that is written in the folder %temp%\CTXReceiverInstallLogs*

Example: CTXReceiverInstallLogs-20200214-201421

 

Here I was able to see that the problem was due to the VC redistributable C++ 2017 since I had the x64 version but the installer requires the x86 version. After installing it the Workspace installed with no issues.

 

Log example:

20:14:25: Information - CApp::IsRequireToInstallVCRedist(2434) - Checking for isntalled VC Redist 2017
20:14:25: Information - CApp::IsRequireToInstallVCRedist(2439) - Found the installed VC Redist version details as ,  14.24.28127.04
20:14:25: Information - CApp::IsRequireToInstallVCRedist(2443) - Need to trigger installation for 32 bit VC Redist

 

Hope this helps. Regards.

  • Like 2
Link to comment
  • 0

Hello,

 

I had seen this article but even executing the installer with Run as administrator, the error still occurs.

From what I understand there is a newer version of the .Net Framework installed on my machine, but the installer does no seem to identify this version, and when it tries to install the .Net Framework 4.6.2 or later, it gives an error because windows does not allow it to be installed since there's a more recent version available.

 

When I try to install the .Net Framework 4.6.2 manually it is block by the same reason, windows blocks the installation since there's a newer version installed.

 

Also in windows features the only .Net Framework available for activation is the 4.8. I tried to select everything, deselect everything from this but with no success.

I even tried to activate the .Net Framework 3.5 but this also didn't work.

image.thumb.png.beb38860c8823c054bf33b4fae608e93.png

 

I'm kind of stick now, don't seem to have any more ideas, so suggestions are welcome.

 

Thanks and regards,

 

image.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...