Jump to content
Welcome to our new Citrix community!

Issues after updating to newer 13.0-Firmwares


Jens Ostkamp

Recommended Posts

Hey everyone,

 

I wanted to ask if anyone experience similar issues when upgrading to newer 13.0 Firmware versions?

I've been using the 36.27 Firmware mostly which works perfectly fine. 

After updating the one of the newer releases I had a lot of issues I could only fix by downgrading to 36.27 again.

 

For example:

41.20 broke pre-auth for exchange completely (error after trying to SSO me into OWA which definately came from NetScaler)

47.22 constantly showed me "404 not found" when trying to access the two NSGW vServers. Interestingly Receiver Access worked great.

 

These two issues were on different appliances in different infrastructures .

 

Can anyone relate to this? So far only 36.27 seems to work stable.

 

Best regards!

 

Link to comment
Share on other sites

I did experience the same behavior with ADC 13.0 47.22 "404 not found" when trying to access a Gateway server on the appliance.  I did downgrade the appliance and the Gateway server works.

 

Opened a ticket with Citrix and uploaded a support bundle, but did not had the opportunity to work on this.  But I did notice someone else reporting that some vpn files may have been possibly missing.  I believe this occurred in the past with another build where some files were not included.

Link to comment
Share on other sites

  • 1 month later...

I'm on 47.22 for SDX and 47.24 for VPX and seeing only two issues which appear minor but are consistent across all VPX's and admin/GUI related since I have no issues with services or via SSH.

If logging in through webbrowser and leaving it for a little while, page will get blank and I need to close/login again, this never happened in previous versions, but it's no big issue, the other is more nagging since I can't yet locate the cause for it, but sometimes when viewing/editing a LB VIP through the web interface the browser becomes extremely slow and sometimes "hangs" with message like "enumerating SSL certificates" or similar errors. Again no issue if done through SSH and no noticed problems in actual performance/routing so I'm treating it more as a graphical glitch until I know more.

Link to comment
Share on other sites

I have had this issue with hanging browser as well. Something with SSL Certificates / bindings seems to be not working correctly.

I also had an issue, where i bound a certificate to a vpn vserver and after i checked the certificate binding with an external site (sslshopper.com) it still showed the old certificate, GUI showed me the correct binding, CLI showed me the old binding. When I tried to unbind the certkey via CLI i got errormessage that this certificate doesnt exist. Only after completely re-adding the whole vserver it worked correctly. I only had this issue with the security fixed 13.0 firmware, older 13.0 firmware worked correctly regarding certificates but i had other bugs (mentioned in start post)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...