Jump to content
Welcome to our new Citrix community!
  • 0

Citrix ICA Client .ica wont Point to Citrix Connection Manager

Jacob Day




I have a user who cannot get our PI application to launch through webcitrix,


I have a alot of users that use Workspace with no problems. The only difference I can see between them and the user having problems is the file association for .ica is different. The working user's .ica points to Citrix Connection Manager, and the broken user's .ica points to Citrix Workspace. I have tried everything I could think of or find to change the .ica association to Citrix Connection Manager for the broken user but nothing seems to work.


What I have tried

Changing the default app for .ica (No option for Citrix Connection Manager is shown)

Going through CMD and manually entering the command: assoc .ica="C:\Program Files (x86)\Citrix\ICA Client\wfcrun32.exe" the path is correct. no luck


The only thing I couldn't do that I found was here


On step 1 for Windows it says to find the .ica and select open with. I couldn't find the .ica on the working users or on the broken user's machine.


The broken user's account for webcitrix works on other machines, so I know the account is fine.


We think the problem is with the default file association not pointing to Citrix Connection Manager

Any help is greatly appreciated 


Windows 10 64 bit

Citrix Workspace version, tried both 1909 and 1907. All users have version 1909

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...