Jump to content
Welcome to our new Citrix community!
  • 0

USB Printer and an Igel thin client.


John Litster

Question

I am publishing a Windows Server 2016 user desktop on an Igel thin client.   VDA is 1906.2

I can print to network printers just fine.

My issue is, when I plug a usb printer into the thinclient.

Windows sees the printer.   In device manager, I can see the printer, if I pull the usb cable out, it goes away, when i plug the cable back in, it re-appears.

When I try to print, i get an error saying that it can't print, and the print job stays in the queue.

 

For policies, I do have "auto-create client printers" , "client printer redirection", "universal print drive usage"

another policy that has "client usb device redirection", "client usb device redirection rules","client usb plug and play device redirection","universal drive preference" (ps/xps/emf/pcl5c/pcl4), "univerals print driver usage" (use universal printing only if requested driver is unavailable)

 

I also installed the print drive on the base image machine.

 

on the windows printer properties, it shows that the driver is "HP laserjet P1505n class driver"   (that is the printer type)

 

Windows event log/system says "The USB device with Product ID: 0x0002, Vendor ID: 0x1d6b, and Device ID: 0x418 cannot be redirected because the Citrix USB Service policy, "DENY: ...class=09..." is in effect. Refer to "CTX137939" for instructions on creating USB policy rules."

 

 

Any ideas??

 

 

Link to comment

5 answers to this question

Recommended Posts

  • 1

Ok, got this working a few weeks ago, just forgot to post the fix.

 

Tried adding the ID in a policy, didn't work....tried countless other things.    THe 'fix' just doesn't make sense.

 

On the back of teh igel device, there are 3 usb ports, and 1 on the front.

I discovered, by accident, that if the printer is plugged into one of the HORIZONTAL usb ports, it would work.   1 on the back, and the one on the front are horizontal, the other two on teh back are verticle.    Even though windows would 'see' the printer in device manager when plugged into the verticle ones, it just wouldn't print and give the various errors i posted here.

But when plugged into a horizontal port, life is good.

I reported that issue with igel.

 

 

  • Like 2
Link to comment
  • 0

I was kinda thinking something like that might be the issue, but I was thinking that if it really was an issue, there would more more posts about it.   And all the refferences I saw on how to fix it was all really old.

In the policy I had created for this....I had already added the "Client USB device redirection rules" with the default value checked.

Prior to following the link you gave, In device manager I could see "Universal Serial Bus Controllers/USB Printing Support"

I unplugged teh USB cable, it went away, plugged it back in and it re-appeared.   I went to the details of that then got the settings from the Hardware Id's dropdown 

Allow: VID=03F0 PID=4017

I added that to the policy.

Ran Gpupdate /force on the Citrix DC, and again on the VDA.

Logged back in and noticed that the printer was not showing at all.

Went back to device manager, the 'usb printing support' entry was missing as well.

went back to the policy, set it back to default settings....did the gpupdate dance again, logged back in and the printer returned.

(Then discovered don't put a space between ALLOW:  and VID)

 

but anyway, after adding the rule, the printer returned as it was before.....and operates as before.

 

as soon as I tell it to print, it instantly gives an error saying it failed.

 

 

devicePID.jpg

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...