Jump to content
Welcome to our new Citrix community!
  • 0

How To Set Xen Ubuntu 18.04.3 Guest To MTU 9000


Jan Rasche

Question

Hi Community,

 

I have a problem setting the MTU in a Ubuntu LTS VM to 9000.

 

Host:

[root@xs2 ~]# xe vif-param-set uuid=e096082c-71bc-0eed-8424-15e4c6fdb794 MTU 9000
Error: Field 'MTU' is read-only

VM:

backup:(/)# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500

backup:(/)# ifconfig eth0 mtu 9000
SIOCSIFMTU: Invalid argument


backup:(/)# ip link set eth0 mtu 9000
RTNETLINK answers: Invalid argument


 

How do I achive this?

 

(The host VLAN and bond are at 9000.)

 

Thanks, Jan

Link to comment

4 answers to this question

Recommended Posts

  • 0

@Tobias

You mean the setting on the VM is working, if it is down?
xe vif-param-set uuid=e096082c-71bc-0eed-8424-15e4c6fdb794 MTU 9000

The VLAN and Bond the VM is using are 9000 on the host already. The VM was imported and did not inherent it when created from imported template.

 

@Jose

No, I do not have it in the VM network tab. There is no MTU setting here in XenServer.

I only have this for the network tab of the host itself. There ist the MTU 9000 aready set for the VLAN and the Bond the VM ist using.

 

Best, Jan

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...