Jump to content
Welcome to our new Citrix community!
  • 0

Problems importing Citrix Application Layering v1902 OVA into XS 7.6 (2018.0829)


Alan Osborne

Question

Hi,

 

I'm trying to learn about Citrix Application Layering, but I can't get the first step completed - importing the OVA. The issue is that XA 7.6 won't import the OVA, which I freshly downloaded for Application Layer v1902.

 

In XenCenter, it just shows "failed to import"...

 

I'm using the steps outlined in the documentation (https://docs.citrix.com/en-us/citrix-app-layering/4/install-appliance/citrix-hypervisor.html)

 

  • Extract the Citrix Hypervisor_elm_4.x.x.x.ova file to a folder on your local drive.
  • In your XenCenter client, select File > Import.
  • In the wizard that opens, select the following values:
    • Import Source - Browse to the source on your local drive.
    • Location - Choose the Citrix Hypervisor where you want to deploy the appliance.
    • Storage - Use the default value to put storage disks on the Local Citrix Hypervisor Storage.
    • Networking - Select the correct network for your Citrix Hypervisor configuration.
    • Security - This tab is not available. Click Next.
    • OS Fixup Settings - Select Don’t use Operating System Fixup.
    • Transfer VM Settings - Choose the correct network and choose DHCP.
    • Finish - Review your settings and then click Finish.

 

In the XC logs, there are these relevant entries:

 

2019-04-08 17:16:14,397 INFO  XenOvf.OVF [Main program thread] - Import.Process: Found a VMWare Virtual Hardware Section (Rating: 4) [vmx-08]
2019-04-08 17:16:31,791 INFO  Audit [Main program thread] - Operation started: ImportApplianceAction: VCIT: Pool 72fb6731-548d-61aa-c718-24139642c25d (VCIT): 
2019-04-08 17:16:31,791 INFO  XenOvf.Utilities.Tools [116] - Utilities.OpenArchive: Opening OVF Archive: C:\temp\xenserver_19.2.0.7.ova
2019-04-08 17:16:31,791 INFO  XenOvf.OVF [116] - OVF.OpenOva: TouchFile: C:\temp\xen__1616
2019-04-08 17:16:31,791 INFO  XenOvf.OVF [116] - OVF.OpenOva: Previously Opened, using extracted files.
2019-04-08 17:16:31,806 WARN  XenOvf.OVF [116] - Version not set, applying 1.0.0
2019-04-08 17:16:31,806 ERROR XenOvf.Utilities.Tools [116] - ValidateXmlToSchema Exception: Could not find file 'C:\temp\xenserver_19.2.0.7.ovf'.
2019-04-08 17:16:31,806 ERROR XenOvf.OVF [116] - OVF descriptor is invalid.
2019-04-08 17:16:31,806 ERROR XenOvf.OVF [116] - OVF Failed Validation, OVERRIDE return success
2019-04-08 17:16:31,806 INFO  XenOvf.OVF [116] - Import.Process: Found a VMWare Virtual Hardware Section (Rating: 4) [vmx-08]
2019-04-08 17:16:31,898 INFO  XenOvf.OVF [116] - Import.Process: Found a VMWare Virtual Hardware Section (Rating: 4) [vmx-08]
2019-04-08 17:16:32,225 INFO  XenOvfTransport.Import [116] - Import.isURI: File: unidesk_xenserver-system.vhd is not in URI format.
2019-04-08 17:16:32,303 INFO  XenOvfTransport.Import [116] - Import.ImportFileProc: ThreadID: [116]
2019-04-08 17:16:32,319 INFO  XenOvfTransport.Import [116] - Import.isURI: File: unidesk_xenserver-system.vhd is not in URI format.
2019-04-08 17:18:43,548 ERROR XenOvfTransport.iSCSI [116] - Failed to start Transfer VM. There was a failure communicating with the plugin.
2019-04-08 17:18:43,548 ERROR XenOvfTransport.Import [116] - Failed to import a virtual disk over iSCSI. Failed to start Transfer VM.
2019-04-08 17:18:43,548 ERROR XenOvfTransport.Import [116] - Failed to import.
2019-04-08 17:18:43,548 ERROR XenOvfTransport.Import [116] - Failed to add resource Hard Disk Image. Failed to import.
2019-04-08 17:18:43,548 ERROR XenOvfTransport.Import [116] - Failed to import virtual disk from file unidesk_xenserver-system.vhd to storage repository 1f4987fc-9292-23d1-e989-1da5c14de1ca.
2019-04-08 17:18:43,595 ERROR XenOvfTransport.Import [116] - Failed to import.

 

It would seem that the OVA created by Citrix isn't actually intended for XenServer (based on the "Found a VMware Virtual Hardware Section" error above).

 

I also tried importing the OVA using "xe vm-import filename=", but that also failed. Lastly, I extracted the contents of the OVA and tried importing the OVF instead - still didn't work...

 

Any ideas?

 

Link to comment

16 answers to this question

Recommended Posts

  • 0

Thanks for the suggestion Boby. Unfortunately, importing one of the VHD files (the OS system disk) didn't work either. I even deleted and recreated the Transfer VM as per this article:

 

https://support.citrix.com/article/CTX215142

  • Set a default SR for the pool in XenCenter
  • Run the script to uninstall Transfer VM if it already exists /opt/xensource/packages/files/transfer-vm/uninstall-transfer-vm.sh
  • Run the script to install Transfer VM /opt/xensource/packages/files/transfer-vm/install-transfer-vm.sh
  • If Transfer VM installs successfully, import VHD and it should work without issue

Unfortunately, that didn't help...

 

I also tried importing to the local SR instead, to eliminate a firewall issue with iSCSI (the default SR is iSCSI based). No luck. I'm rebooting the XS hosts now and I'll try again after they come back up.

 

Not sure what else to try, but I'll post back if I have any further info to share...
 

Link to comment
  • 0

Thanks for the idea! I did exactly as you suggested - I copied the OVA to an existing VM on the same host as the Transfer VM (master in pool), installed XenCenter on that VM, then connected XenCenter to the same host (master) and tried running an import of the OVA again...

 

Unfortunately, failed at exactly the same point. The "Transfer VM for VDI UUID" gets created from the template, but it never seems to boot nor get an IP address on the network...

 

 

Link to comment
  • 0

Well, I finally got the OVA imported but it really shouldn't be this difficult...

 

I found a reference in the Transfer VM's documentation to a "RawVDI transfer protocol" option here:

 

https://docs.citrix.com/en-us/xenserver/current-release/vms/import-export.html#the-transfer-vm

 

By editing the CONFIG file for the XenCenter EXE, I was able to successfully import the OVA via the RawVDI protocol.

 

I've opened a ticket with Citrix to find out why the default iSCSI protocol isn't working, despite the fact that both XS hosts already have iSCSI connectivity to the default SR and the fact that I temporarily tweaked the Starwind HA target to allow connections from all iSCSI initiators.

 

Thanks for your help guys, will post back if I get a resolve from Citrix on the iSCSI related issue with the Transfer VM, in case it helps someone else in future...

Link to comment
  • 0

I did try that, but the VHD import likewise failed - didn't like the format of the VHD for some reason.

 

Citrix really needs to make the Application Layer Manager VA available in XVA format, rather than in OVA. That would solve the issue, as I'm able to import XVAs without issue. In fact, I couldn't find a single OVA, that's intended for use with XenServer, as all other Citrix VAs I could find are in XVA format already. Was hoping to recreate the issue with this one OVA, as I suspect it's an iSCSI related issue, but as I said I couldn't find any other non-VMware/KVM OVAs...

Link to comment
  • 0

Hello,

 

I am relatively new to XenServer and was having the same issue importing the Enterprise Layer Manager.   No matter what I tried It would not import the OVA and I was seeing ISCSI errors in the XenCenter.log file for the Transfer VM.  What worked for me was to bring up another XenServer that was not part of the pool and then I was able to import the OVA with no issues.     Not sure exactly what is different, but hey it worked.

Link to comment
  • 0

I should have posted back here, totally forgot about this thread...

 

Apparently, a permanent fix for this issue will soon be available as part of hotfix XS71ECU2014. In the meantime, there is a workaround...

 

Via an SSH session, do the following:

 

  • Identify a "Transfer VM" template by using the command: xe template-list | grep -i "Transfer VM"
  • Note the uuid of the Transfer VM template
  • Verify the settings of "transfervm_installation_host" by using this command: xe template-param-list uuid=<template_UUID>  | grep transfervm_installation_host
  • Note the output of that command
  • Apply the featureset parameter to the Transfer VM template using this command: xe template-param-set uuid=<template_UUID> platform:featureset=17c9cbf5-86b82203-2191cbf5-00000003-00000000-00000000-00000000-00000000-00001000-8c000000
  • Perform a VM import to verify that imports are now working

 

Root cause is that the existing code relies on a CPU chipset feature that doesn't exist in older Xeon CPUs, but Citrix support didn't provide any details on which feature they rely on...

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...