Jump to content
Welcome to our new Citrix community!
  • 0

Server 2016 | Black Screen + non responsive start menu

Ricardo Holdorf


Hi there,

after all the threads i read and many many tries i have done, i have to ask for your help.

I have about forty workers with Server 2016.

And sometimes it  happens that some VDA drops really long blackscreen phase and after the black screen is gone the start menu is not responsive with the left mouse click.


So i tried older UPM Version and also a newer UPM Version (7.15ltsr cu1, 1811).

When i stop the Appreadiness Service i have really fast login, but the startmenu is not working. When i logon to another Worker all is fine.

Export/Import the Regkeys AppReadiness and Appx doesn't affect anything.


The eventviewer shows me also problem with Appreadiness Service ID 225 ,,operation failed".


So any suggestions on that?

Link to comment

7 answers to this question

Recommended Posts

  • 0

So... lets not start a discussion about how and why all these type of different issues with Win10 and Win2016 start menus occur or the numerous possibilities you could implement to get this wonderful abomination of a start menu working. I have tried all suggestions you could find using my search buddy Google to get this start menu issue resolved, and up until now i have found one that works for me and my situation. Take not, this may not be the solution for you but you might as well try it because there are more ways to get this thing running again.


My case is exactly the same as this topic describes: Blackscreen during login and a non-working start menu on Windows 2016 server with XenApp 7.15 CU3 LTSR.

This issue occurs when one of my users logs on to one of my provisioned session hosts and the "Runtime Broker" process and "App Readiness" service start to reregister AppX packages in the background. Now both process and service are the culprits in this start menu disaster. All new subsequent users that logon to this session hosts will experience black screens for several minutes and after a visible desktop a non-working start menu.


When looking at the user that initiated this issue, you will probably find multiple "Runtime Broker" processes running under this users.  Normally there should be only one single "Runtime Broker" process running. You will also find in registry “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore” several SIDs belonging to logged on users. The user that initiated this issue will have fewer AppX registration entries and subsequent users will have blank AppX registration entries




Once a user is stuck in the black screen at logon (takes several minutes to resolve by it self), you should stop the  "App Readiness" service. This will immediately resolve the black screen for this user. Start Menu will not work though. By logging off the user that initiated this issue and all other subsequent users with non-working start menus, the issue will be temporarily resolved.


We decided to disable the "App Readiness" service and since then we do not experience any black screen of non-working start menus. Also the “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore”does not contain any user SIDs when this service is disabled.


Like i have written before, this may not be the solution for your start menu related problems. I did in my case.


Link to comment
  • 0
On 9/30/2020 at 2:08 AM, Chuck Snyder said:

Have you had any issues after you disable AppReadiness service for a new logins or existing ones?

when appreadiness is turned off, the start menu sporadically does not respond at all for about 2-10 minutes and when it works again, sometimes you have to click the start button twice to open it. but not for every session.. in one session it works, in another it dont.

w're using server 2016 + cvad 7 1912 cu3 + fslogix + Startmenu is redirected to netshare

Appreadiness will disabled by a script, after the server have rebootet and no user is logged on.

Edited by Florian Lehmann
forgot something xD
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...