Jump to content

AlwaysON VPN Network Access - Captive Portal


Recommended Posts

I'm working with a customer that wants to switch over to NetScaler Gateway Plug-in for their VPN needs, however in it's currently implementation I can't seem to get around the dilemma posed by Hotel and other public wifi hotspot Captive Portals. The policy *must* secure the laptop's network connection so that connections only are serviceable once secured through authenticating to the gateway. The only setting for this is 'Network Access on VPN Failure Only to Gateway'. Unfortunately, a lot of these users roam/travel and are unable to authenticate to Captive Portals because the web page will not load (no network until the Gateway is authenticated). I tried enabling Local LAN Access, but in my testing, that did not resolve this issue. It's sort of a chicken-egg problem where the Gateway Plug-in won't allow traffic to load a web page, and the wifi hotspot won't allow the gateway to load. Other VPN solutions get around this, certainly Citrix has a way? I can't find anything remotely addressing this common concern.

Link to comment
Share on other sites

The Safe Harbor terminology was retired a few years ago. We moved to feature release (FR) and maintenance phase ( MP). 

12.0 has not reached MP status yet as new features are still being delivered. 

 

Ideally you want to be able to test this prior to roll out. If you do not have a test NS. You can always disable the plugin upgrade. Only upgrade the NS and than selectively upgrade users to test ( users installing the new 12.0.58.x plugin manually)

 

Val 

Link to comment
Share on other sites

  • 2 years later...
On 8/7/2018 at 7:59 PM, Valeri Bonchev said:

Hi.

 

Which version of the NetScaler and VPN plugin are you using? Support for Captive Portals and Always on was added in 12.0.51.x this support was later expanded for proxy support in 12.0.58.x. 

 

Val 

Hi,

 

I can’t seem to find any details about the proxy support. I have managed to get always on working through a captive portal but only if I turn of my proxy settings. 
 

Thanks

 

Paul 
 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...