Jump to content
Welcome to our new Citrix community!
  • 0

The problem with load CPU 100% on the VM after the export VM from host to another host.


Andrey Senichenkov

Question

Hello!!

I was looking for a solution to the problem in Google, but I did not find it.

 

I installed Ubuntu 14.04.5 LTS with Xentools on Citrix XenServer 6.5 with SP1, the specification of the host is as follows: Intel Xeon X3430, 12GB RAM, local storage of HDD 512Gb. After the configuration of the VM, everything works fine, CPU utilization is not more than 10%. configuration VM: 4 vCPUs, topology: 1 socket with 4 cores per socket, 6000 Mb RAM, local storage on HDD (60Gb)

 

After exporting the VM(.xva file) to another host (with the following configuration: Intel Core 2 Quad Q6600, 12GB RAM, local storage of HDD 512Gb) the VM began to lag terribly and brake, while XenServer on the new host did not show a large CPU load, although the CPU load in the VM was jumping to 100%

 

For the test, I export the same VM to another host with CPU: Intel Xeon E5405 and the situation was repeated, the CPU VM load jumped to 100%, VM lagged and braked.

 

Do I understand correctly that this situation is connected with the incompatibility of processors? Is this indicated on the page? https://docs.citrix.com/fr-fr/xencenter/6-5/xs-xc-vms-exportimport/xs-xc-vms-export.html

 

I have almost all servers with different processors, how can I transfer virtual machines from host to host so that they work correctly and predictably? Maybe there is a special kind of export or additional settings?

 

If this problem can not be solved, then between which processors can you transfer virtual machines? maybe there is a compatibility table?

 

CPU idle time VM before and after export:

5afec81a9a121_Screenshotfrom2018-05-1815-03-07.thumb.png.604924deff89ad6a6566549558fc45a7.png

 

 

CPU load VM before export:

5afec8279631b_Screenshotfrom2018-05-1815-18-37.png.b5c81b36cc9a8cac4097c2dee7ab0ac4.png

 

 

CPU load VM after export:

5afecbb996c75_Screenshotfrom2018-05-1815-48-48.png.88fccd7c9543df284304b15512ec6bc2.png

 

Link to comment

7 answers to this question

Recommended Posts

  • 0
On 5/18/2018 at 6:56 PM, Alan Lantz said:
On 5/18/2018 at 6:56 PM, Alan Lantz said:

Thats interesting, especially if all hosts are save version/hotfix level. I take it export/import was with XVA format. 

The only thing I could suggest is a removal of XenTools, export, import, then reinstall XenTools. 

 

--Alan--

 

Yes, I tried to do export of virtual machines both with Xentools and without Xentools, reinstalled several times, there is no progress.

 

 

Link to comment
  • 0

 

On 5/18/2018 at 7:25 PM, Tobias Kreidl said:

Even XenTools should not cause that extensive a degradation of performance. Weird. If you import that same XVA file into the original server, I wonder how it would behave?

 

-=Tobias

When I import the file in the first host (Intel Xeon X3430), the virtual machine works without problems! Also this virtual machine works without problems on another host with the same processor (Intel Xeon X3430), which gave the idea that the problems with VM are related to the incompatibility of host processors.

I'm trying to figure out how to solve this situation.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...