Jump to content
  • 0

Unable to import OVF VM


Marcus Peterson

Question

Hello All,

 

I am having a very hard time importing an OVF file to my XenServer 7 Pool.

 

After fumbling a few times and pouring over documentation I have been able to fix/determine a few things.

 

1. I have created an ISO Repository so that the Import Wizard can use the Operating System Fixup ISO while attempting to import the OVF file.

2. I have tested importing this OVF file from different source networks within my environment as well as placing the Transfer VM on different networks.

3. I have found that placing my transfer VM on a network that both XenCenter and XenServer can communicate the import fails after roughly 2 minutes (instead of 48 seconds). This seems to be related to iSCSI failing.

4. After dumping network traffic at my host machine it appears that iSCSI is failing to establish. This happens a number of times before the Transfer VM shuts down and the import fails. (See screenshot below)

 

.104 is the XenCenter.

.254 is the Transfer VM.

 

One question I have is this. My SAN is isolated from the rest of my environment (Only the SAN and Xen can communicate). According to documentation the Transfer VM just needs to be able to communicate with XenCenter and XenServer. However I am wondering if the Transfer VM needs direct communication with the SAN.

 

Either way. This has become a pressing issue.

 

Can someone please assist me with this situation?

 

Thanks in advance!

wiresharkCapture.PNG

Link to comment

11 answers to this question

Recommended Posts

Hey Tobias,

 

Thank you very much for your response.

 

I always use XVA files as well. However in this situation I must get this third-party OVF file imported to my Xen pool. I have had no issues at all importing XVA files in the past. Although if I am not mistaken, the Transfer VM is not used when importing XVA files? Usually I export VM snapshots. Then once imported, I create a new VM.

 

I have tested deploying this OVF file using another virtualization platform (VirtualBox) and it works without issue.

 

I am puzzled by this situation.

 

Is there somewhere within XenServer that I can get more verbose log output? At the very least something more meaningful than XenCenter's 'Failed to Import' message?

 

Thank you tremendously Tobias!

--Marcus

Link to comment

Hey Tobias,

 

I attempted to convert the OVF file using XenConvert v2.1.1 (I'm guessing that's an old version) which caused my workstation to blue screen.. I noticed according to the link you sent me that Citrix XenServer Conversion Manager is the preferred conversion tool as of XenServer 6.1 and higher. However the only download I was able to find for that was an ISO. I'm not sure what that's about.

 

I then decided to attempt using nested virtualization on top of my Xen environment. But alas.. The VM within the nested hypervisor failed to boot stating that it requires x86_64 for some reason..

 

I'm at a complete loss here at this point.

 

Do you have any recommendations?

 

Thanks Tobias,

--Marcus

Link to comment

Bummer, Marcus. You're right that the conversion manager is the newer way to tackle this. Sorry it still did not work. Only other thought might be to pull it into a VMware environment and make sure any tools are uninstalled and try to export it again. An OVF file should be a giant XML file, and the last thouhgt I have is whether there's a chance it either (1) got damaged, or (2) has some weird conversion issue like extra CR/LF characters from Windows file systems or the like. I'd also consider trying to get hold of some OVF file just to prove it actually works, in which case the suspicion falls back upon a possible damaged file.

 

-=Tobias

Link to comment

The moment the transfer VM is up , the IP assigned to it should be pingable.


Also it should show up as a running vM in a grey colour. Again,  if you make a note of the time frame of start of operation , we can probably look at the logs and understand further.

( I am fairly confident about looking at xensource.log ) 

the error message that appears on the console of the Transfer VM during the failure would also help. 

Link to comment

I do not create a new thread - my problem is the same.
I spent 2 weeks looking for a problem. I found the source of the problem!
We have full chassins of IBM Blade - 14 blades.
I created a pool of 7 blades with shared FC storage.
In the next step, I tried importing all types of VMs: ova, vmdk, vhd - no results.
In each attempt I received Failed Import.

Quote

Nothing interesting in logs: Failed to import. ---> System.IO.InvalidDataException: Failed to add Hard Disk Image resource. ---> System.Exception: Failed to import. ---> System.Exception: Failed to import virtual disk file. ---> System.Exception: Failed to import a virtual disk over iSCSI. ---> System.Exception: Failed to start VM Transfer. ---> XenAPI.Failure: There was a failure communicating with the plugin.

I read all the instructions in the forum, in the manual, the blog - no result. I thought the problem is in the network settings ..
Today I made another attempt. I connected the same shared storage to blade no. 8 (not pooled)
This blade is like a clone of this 1-7 in my pool -  has access to the same switch, assigned the same ip address, etc.
So .. Now I've tried to import VHD - Success, no problem with transfer.

And there is my question.
Where to find import problem in XenCenter if servers are in pool?

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...