Jump to content
Welcome to our new Citrix community!
  • 0

Iscsi Multipath - unknown key DMP

Stuart Rickards


Hopefully someone can help with this issue.


I am trying to configure a shared iscsi storage repository in xenserver 7.1, however when i try via the cli i get 

the target device is a fujitsu eternus DX60 s3 which is on the HCL



Error reporting error, unknown key DMP failed to activate mapper path,


i get the same error via xen center.


multipath -ll gives


mpatha (3600000e00d290000002908f600000000) dm-1 FUJITSU ,ETERNUS_DXL     

size=18T features='1 queue_if_no_path' hwhandler='0' wp=rw

`-+- policy='round-robin 0' prio=5 status=active

  |- 75:0:0:0 sdb 8:16 active ready running

  |- 79:0:0:0 sdc 8:32 active ready running

  |- 81:0:0:0 sde 8:64 active ready running

  `- 80:0:0:0 sdd 8:48 active ready running



my multipath.conf file is as below


# This configuration file is used to overwrite the built-in configuration of

# multipathd.

# For information on the syntax refer to `man multipath.conf` and the examples

# in `/usr/share/doc/device-mapper-multipath-*/`.

# To check the currently running multipath configuration see the output of

# `multipathd -k"show conf"`.

defaults {

user_friendly_names     yes

queue_without_daemon    no

#find_multipaths yes


blacklist {

devnode "^nvme.*"


# Leave this section in place even if empty

blacklist_exceptions {


devices {

device {

vendor "FUJITSU"

product "ETERNUS_DXL"

prio alua

path_grouping_policy    group_by_prio

path_selector "round-robin 0"

failback immediate

no_path_retry 10

path_checker tur

dev_loss_tmo 2097151

fast_io_fail_tmo 1



Link to comment

9 answers to this question

Recommended Posts

  • 0

HI Tobias,


We are facing an strange issue in our xenserver 6.5 after expanding LUN size on storage,


History -


there are two xenservers in our pool and lenovo 1200s storage LUN is mapped with it, some days ago we were running out of space hence we had expanded space in the LUN but expanded space was not detecting by servers, so in order to get the expanded space detected on the server we tried to detach and attached SR (iscsi over LVM) again but no avail, expanded space was not detected so we tried to reboot the server in the sequence like first master and then slave but after rebooting VM's list is populated in the xencenter but when we try to start any vm which was created on the storage throws the error no boot disk found, also if we navigate the vms storage info it doesn't show vm partition path. but storage is connected properly to the server as we tried to create test vm in the same storage and we were able to create it. 


we ran these commands to unplug and plug in storage in the xenserver


1) Shut down all VMs on the SR.

2) # iscsiadm -m node -R

3) xe pbd-unplug uuid=<PBD UUID>

4) xe pbd-plug uuid=<PBD UUID>

5) Restart Hosts


kindly suggest me how to get the vms back from the same storage without data loss as the vms are critical for business.




Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...