Jump to content
Welcome to our new Citrix community!
  • 0

Director/NMAS integration

Werner Van Zyl1709157339


Hi everyone


recently did a Netscaler MAS deployment but still struggling get the integration with Director to work.


Director 7.11

Netscaler 11.1

Platinum license

Latest version of NMAS


Followed the DirectorConfig /confignetscaler setup and used (1) for NMAS and (1) for https connection.  completed successfully


In Director, on the Trends Tab>Network the message is:


No details are available

Network unreachable. Check configuration, authentication or service availability


I have 2 director servers and both show it's listening on port 443 (netstat)


NMAS is pulling HDX and other web analytics through and there is no issue from that end.  Director shows all other metrics fine.


Anyone come across something similar with NMAS/Director integration?





Link to comment

10 answers to this question

Recommended Posts

  • 0

Thanks Carl.  There's a wildcard certificate on the director server (director is separate from the delivery controllers). Director has an issued cert from a public CA like GoDaddy.  Testing has been done from the same DIR server (and the 2nd one with the same cert installed, ie *.mydomain.com). 


I added the same *.mydomain.com cert/key on the NMAS appliance.  Am I supposed to link the CA root + intermediate + cert as I would typically have done on Netscaler?  Don't recall seeing a place to link them in NMAS.


I have since upgraded Director to 7.12 and left Director installed with the basic settings (not trying to do SSO or via load balancers) but made no difference.  Also did a NMAS reconfigure for HTTP to see if that made any difference without the Certs which I may have botched - but no change.


Also read an article about mixed content and by default in IE is set to prompt...I set that to allow...but no change.  I am however no longer seeing the No Details available message, just a grey screen on the Network tab.


We run in a mixed mode environment (DDC on 7.6FP3) - in case that makes a difference?  Some features in Director obviously not showing up (like notification Tab) due our DDC version....

Link to comment
  • 0

I ran into this issue with integration, errors in the CDF trace were vague. Upgrading MAS to build 11.1-53 resolved Director integration.  Apparently this build resolves the drive filling up to the point we can't login to the console and had to rebuild, but one environment is already at 80% so cannot confirm this issue was resolved. Director integration is, confirmed in three different deployments.

Link to comment
  • 0

As Carl mentioned above, connection must be SSL and a trusted cert.  We generated an internal AD CA cert which Director server natively trusted, loaded on MAS (reboot required), created a DNS host record for the MAS server and configured Director integration using SSL and the MAS server FQDN.  I haven't tried with a wildcard cert.. yet.  

Link to comment
  • 0

Verify the following ::


1. Use the ADM FQDN instead or IP when configuring director script to reference ADM.

2. Replace the ADM TLS cert with a cert trusted by Director Server.

3. Make sure there are no FW blocking https:443 between Director and ADM.

4. If network capture trace from Director shows TLS handshake problems (and you don't know how to fix them) use HTTP only instead HTTPS when integrating director and ADM




Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...