Jump to content
Welcome to our new Citrix community!
  • 0

Usb redirection and Auto switching from optimized to generic mode


Sove

Question

10 answers to this question

Recommended Posts

  • 0

Please add below registry to enable auto redirection of storage:

HKLM\Software\Citrix\ICA Client\GenericUSB\Devices

AutoRedirectStorage=dword:1

 

Follow article CTX123015

 

Also you will have to select below options in cdviewer preferences:

1. when session start connect device automatically

2. when new device attached connect device automatically

Link to comment
  • 0

Hi Sove,

 

If the device is redirected inside the vda session then on client device manager it will not be listed.

I assume it is the same case for your mass storage device as well.

 

For more clarification:

After your add registry AutoRedirectStorage=dword:1 ,  mass storage will behave as generic device for redirection 

 

But for all generic device to be redirected you always have to select below options in cdviewer preferences:

1. when session start connect device automatically

2. when new device attached connect device automatically

 

So overall you have to add registry and set checkboxes in preference , connections tab for autoredirection to work smoothly.

  • Like 1
Link to comment
  • 0

Thanks for your prompt reply.

Now the redirection in generic mode works.

The problem was that in "Client USB device redirection rule" I have manually inserted some rule like "Allow: class=08"; after I have enabled "Use default value" and with your suggestion the redirection works as I wanted.

Thanks again.

Link to comment
  • 0

Is there any way to force the below?

But for all generic device to be redirected you always have to select below options in cdviewer preferences:

1. when session start connect device automatically

2. when new device attached connect device automatically

 

Nevermind I found this in the user profile keys.

[HKEY_CURRENT_USER\Software\Citrix\ICA Client\USB\Explorer]
"NewDevices"="Always"
"ExistingDevices"="Always"

Link to comment
  • 0
On 4/19/2016 at 4:12 PM, Sove said:

Thanks for your prompt reply.

Now the redirection in generic mode works.

The problem was that in "Client USB device redirection rule" I have manually inserted some rule like "Allow: class=08"; after I have enabled "Use default value" and with your suggestion the redirection works as I wanted.

Thanks again.

Can you be provide more information to redirect specific USB devices as Generic channels rather than optimized channels ??

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...