Jump to content
Welcome to our new Citrix community!

Corrupt Backup - how to delete or remove?

John Weaver

Recommended Posts

Good afternoon.  Thanks for reading this post.

I am working with a MPX NS11.0 64.34.nc system.


Does anyone know how to remove a corrupted backup from the list of backups show by "show backup" or the GUI?


I found what I believe is the file where this information is stored, but in this directory, I did not find ay information about the "file" in question.


Directory:  /var/ns_sys_backup


I checked the nsbackup.txt file found therein.  It only lists the current and only valid backup that is listed by "show backup" or the GUI.

However, both "show backup" and the GUI list a filename that doesn't exist and is not a real backup.  Somehow, text from an e-mail message I sent ended up listed as a backup...


The GUI shows this as a backup:

"Only items missing are those I identified to Dan P.l via e-mail"


Created By:  

Creation Time:  Wed Dec 31 18:00:00 1969

Size: 0 KB


I tried making a fake file and then using the GUI to delete the backup - failed.

I edited nsbackup.txt to list the backup and then deleting the backup via the GUI - responded that this is a corrupt backup.


Unfortunately, the NetScaler device does not appear to provide a method to delete/remove corrupted backups or backups that don't actually exist but are listed.


Is there another config file that I could edit to remove this fictitious listing?  If so, what is it and where is it?



Thank you!




Link to comment
Share on other sites

  • 4 weeks later...


I had the same issue on a Netscaler VPX 11.  For some reason I had two files in that location with the same content (a text list of the backups)


I was able to remove the entries in those two files, checked in the gui and that didn't resolve the issue.

I rebooted the netscaler and then it was correct in the gui.  So you probably need to reboot it after editing those files to show things correctly after the edit(s).

Link to comment
Share on other sites

  • 1 year later...

For anyone that stumbles across this in the future...

A reboot will clear this up as mentioned above.  However, for those who can not or do not want to reboot.


You will need to create a good backup of the same type as the corrupt backups.  So for example 


View current backups (corrupt or non-existent)


>show backup
1)      FileName:  ns-backup-20160209_0601.tgz Level:  full
2)      FileName:  ns-backup-20160211_0601.tgz Level:  full


Create a new good backup.  Note a known good backup can be copied to the NetScaler if you are already at the 50 backup limit.


>create backup ns-backup-20170522_1330 -level full


Drop to the shell




Change to backup file directory


# cd /var/ns_sys_backup/




# ls



find the good backup, in this case ns-backup-20170522_1330.tgz and copy it to the names of the corrupt or missing backups


# cp ns-backup-20170522_1330.tgz ns-backup-20160209_0601.tgz


# cp ns-backup-20170522_1330.tgz ns-backup-20160211_0601.tgz


Exit shell


# exit


and now you can remove the corrupt\missing backups using cli or gui


>rm backup ns-backup-20160211_0601.tgz

>rm backup ns-backup-20160209_0601.tgz



Its the long way around, but if a reboot is out of the question, and you have hit the 50 backup limit, this can be a real life saver instead of downtime.  If your backup naming convention is good, this can be scripted as well.  Hope this helps someone else out.

  • Like 1
Link to comment
Share on other sites

Dan and James,


I appreciate your input.


James - I'm not sure if you noted, but in my original post, I stated that I had created a fake file and then attempted to delete it (from the GUI) and that this failed.  Perhaps I didn't get the filename exactly correct, but I'm usually precise.  *shrug*


Dan - looks like the reboot did the trick.  There was an unscheduled reboot (politically correct term) and the corrupt backup is gone from the list (as I had previously removed the entry from the text file that is the list of backups).



Thanks both,



Link to comment
Share on other sites

Great point, James.

I remember trying a text file and renaming it.

I thought I also tried a backup file. It has been a year and I don't recall for certain.


In any case, I believe the thread here contains great information in case anyone experiences the same issue.



Thanks again for your input.

Link to comment
Share on other sites

  • 2 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...