Jump to content
Welcome to our new Citrix community!
  • 0

Chrome some time black screen

Stefano Mancin


Hi i have a problem with the pubblication of Chrome on my farm.
Some users report that chrome some times (more time a days) hang with a black screen. 
I verified is a problem of video refresh because if press  ALT+TAB key to switch application's windows, chrome return usable. 
No other publish's applications have the same problem.


The configuration are:

Xenapp 6.5 RP3

Storefront 2.1

Receiver 4.1 on windows 7 x64

UPM 5.0


Crome command line : "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --allow-no-sandbox-job --disable-gpu --disable-bundled-ppapi-flash --no-default-browser-check --no-first-run



Any suggestion?




Link to comment

10 answers to this question

Recommended Posts

  • 0

We have tried quite a few things, but none have permanently fixed the issue. One change that helped some users was to change their gmail theme as some had photos, etc. For some having a Light, High Contrast or flat color theme worked.


We have tried bandwidth optimisation policies within Citrix policies but that didn't help either. We also upgraded their Receiver to v4.3 which didn't make a difference.


Finally, we are now testing by putting Chrome into compatibility mode as Vista SP2. We should know by next week if this works or not.

Link to comment
  • 0

Did anyone ever find a solution to this issue?

I just replaced some Windows XP POS systems with newer Windows 7 systems.

On the newer systems users experience this issue. Chrome session goes black after a period of time but other application sessions stays OK.



Setup is:

Xenapp 6.5 RP3

Receiver Enterprice 13.4.300.10

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"  --allow-no-sandbox-job --disable-gpu --disable-print-preview


I’ve also rarely seen this on my Windows 10 using Receiver 4.1

Link to comment
  • 0

I had a similar issue on win 8.1 and realized it was the task bar thumbnail for Google Chrome causing the issue. Try disabling the thumbnail.


Me and my users still experience this issue.

Also in my Windows 10 client now using Receiver 4.5.

Google Chrome session becomes unresponsive or black but other published applications from the same Xenapp server continue to run.


Not 100% sure how to disable taskbar thumbnail. Do you mean "HKLM\SOFTWARE\Citrix\ICA Client\Engine\Lockdown Profiles\All Regions\Lockdown\Virtual Channels\Seamless Windows\TWITaskbarGroupingMode=GroupNone”?

Link to comment
  • 0

The post ist old but i still had the Problem on a single Virtual Desktop (Virtual Machine) in December, 2019


So here is a Solution that worked for me:

  1. Uninstall your Citrix VDA on the Virtual Machine with Administrator Rights (if you use an software distribution you can use it for the process)
  2. Restart the VM
  3. Install the current Citrix VDA on the Virtual Machine with Administrator Rights (if you use an software distribution you can use it for the process)
  4. Restart the VM

Try to connect with the VM per Citrix. You may need to do this two or three times.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...