Jump to content
Updated Privacy Statement
  • 0

Cannot connect to " - Published app name" Most Distros

Keith Pawson


Posting this as a new thread question as not much response from a thread.

Having this issue and can't believe hardly anyone else is reporting it. I'm trying to connect to a Citrix server farm that I run and built via CAG and can use Windows, Android and iPad's to connect with no issues. However, when I try Ubuntu I get the same issue as listed in the subject or specifically:

Cannot connect to " - Published app name"
Operation not permitted. Verify your connection settings and try again.

I've have tried with Ubuntu 12.04 32bit and 64 bit, Ubuntu 12.10 64bit Linux Mint Mate 14, latest Fedora 18 and all provide the above error. I found some sites after a Google search stating this is a proxy issue, however I'm not using a proxy, and have tried two different Internet connections and also a 3G dongle connection on a laptop. I'm using the latest Receiver from the Citrix website 12.1 and have tried with and without Openmotif installed, but I really only need to login via the CAG with Firefox and launch the published apps, so I believe I don't need OpenMotif?

The only distro I've managed to get some success with is Luninux http://luninuxos.com/ however I think that's because they have pre-packaged the receiver via Wine or something, and the published apps don't run correctly, have weird response and they get stuck.

About 18 months ago I used to have an Ubuntu VM running with Citrix working via Firefox with no problems to the same farm and CAG and not much has changed. So I'm guessing something has changed with the receiver or with version 12.xx of Ubuntu? I've ran a TCPDUMP and can't see anything being dropped from my end, check the firewall at the CAG end and it's just listing my IP address as being connected.

I would really appreciate any help with this, and need to get it working with Ubuntu 12.04 32bit for starters - can anyone help?


Link to comment

14 answers to this question

Recommended Posts

  • 2

This is most likely a problem with the certificates shipped with the Citrix client for Linux, for several versions now. There is a fairly aged article in the Ubuntu Community Wiki giving background information. See Citrix Receiver on Ubuntu 18.04 LTS for details.


Simply remove the installed certificates (on Debian/Ubuntu this is the /opt/Citrix/ICAClient/keystore/cacerts folder) and replace it with a symbolic link to /etc/ssl/certs. Explained step-by-step on AskUbuntu ("Citrix receiver 13.10 on Ubuntu 18.04.1").

  • Like 2
Link to comment
  • 0

I've narrowed this issue down it only being an issue when connecting via the Citrix Access Gateway. Connected laptop on the internal network and it runs perfectly.

So why is it that all other clients, Windows, Mac, IOS and Android work perfectly via the Citrix Access Gateway and the Linux client's get this error?

Anyone from Citrix care to shed some light on this, surely I'm not alone with this? As mentioned I've had older Linux clients connect with no issues, so something has changed with the client?


Link to comment
  • 0

Found the issue!!!

The default.ica file on the web interface server had ProxyUseFQDN=On after changing this to Off e.g. ProxyUseFQDN=Off all my Linux client computers and test vm's work straight up. Don't ask me why Luninuxos worked and the others didn't. Tested with Ubuntu, Mint and Fedora.

But I can confirm that this setting was the cause of the Linux client's not being able to connect to the Citrix Apps via the Access Gateway and all devices/platforms still work too i.e. Windows XP/7, MAC OSX, Android and iOS devices.

However, I must say that to my thinking this is a bug with the Linux client for Citrix, because when this setting is on all devices and platforms except for Linux could connect fine.

Is there anyone from Citrix reading this? If so can you look into this and if not can you just say hello :P

Link to comment
  • 0

Hello Keith,

Thank you for this information.

I'm not very familiar with this functionality, but using these findings of yours I found that a fix for this issue had previously been applied to the Receiver for Windows. I have now added this to the Receiver for Linux, so it should be fixed in the next major release.

As you have a work-around, you may be happy to use that. If not, and you escalate the problem, a fix should be available.

I hope this helps,


Link to comment
  • 0



We are testing a VDI solution and when installing on Ubuntu 18.04 I ended up with this problem


lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04 LTS
Release:        18.04
Codename:       bionic

dpkg -l | grep icacli
ii  icaclient                                                    amd64        Citrix Receiver for Linux



Captura de tela de 2018-05-24 08-08-31.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...