Jump to content
Welcome to our new Citrix community!
  • 0

XML Port Change Urgent Help


Ray Green

Question

14 answers to this question

Recommended Posts

  • 0

Depends how the other servers are configured.

If the other servers were installed as Session Hosts then they will not have the XML service

You only need to make this change on servers that are in controller mode.

You will also need to update your Web Interface config to use the new port.

----------

Shaun Ritchie
[www.shaunritchie.co.uk|www.shaunritchie.co.uk]
[Follow me on Twitter|www.twitter.com/shaunritchie_uk]

Link to comment
  • 0

Ray,

You will need to change the port on the XML Brokers in the farm. These are the servers which the Farm Properties point to in Web Interface.

Basically the steps you need to do are to

1. Configure the Unfiltered Computer Policy so the XML Port is set to 8080
2. Register the XML service on your XML Brokers against port 8080 using the ctxxmlss command as documented in the CTX you mentioned
3. Re-configure the Web Interface site to use port 8080
4. Make sure the firewall is configured to open port 8080
5. Check each XML Broker is listening on port 8080, do a netstat -an | findstr 8080
6. Do a few test app launches

Hope it goes well,

Anthony

Edited by: anthonycu on Sep 26, 2012 10:30 AM

Link to comment
  • 0

> {quote:title=Pavan900 wrote:}{quote}
> The article you have looked is for XenApp 6 only, In XenApp 6 all of the servers have XML Service. There is no concept of Controllers and Session hosts.
>
> If your Citrix farm is XenApp 6.5 then you only need to change the port on controllers.

Exactly, and seeing as this is posted in the XenApp 6.5 forum I am assuming he is using XenApp 6.5.

This is why I posted the links.

He needs to check which servers have the controller role and change the port on all of them.

----------

Shaun Ritchie
[www.shaunritchie.co.uk|www.shaunritchie.co.uk]
[Follow me on Twitter|www.twitter.com/shaunritchie_uk]

Link to comment
  • 0
On 9/26/2012 at 9:29 PM, Anthony Cunningham said:

Ray,

You will need to change the port on the XML Brokers in the farm. These are the servers which the Farm Properties point to in Web Interface.

Basically the steps you need to do are to

1. Configure the Unfiltered Computer Policy so the XML Port is set to 8080
2. Register the XML service on your XML Brokers against port 8080 using the ctxxmlss command as documented in the CTX you mentioned
3. Re-configure the Web Interface site to use port 8080
4. Make sure the firewall is configured to open port 8080
5. Check each XML Broker is listening on port 8080, do a netstat -an | findstr 8080
6. Do a few test app launches

Hope it goes well,

Anthony

Edited by: anthonycu on Sep 26, 2012 10:30 AM

Hi Anthony, I've follow All the step but the citrix web login or web portal not shown in the browser just blank white screen. BUT if I use Citrix Quick Launch portable apps everything runs fine, I can open the application. Did I missed something on the setting ?

 

I am using Xenapp 6.5 on Win server 2008 R2 and IIS 7.0

 

Rgds,

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...