Jump to content
Welcome to our new Citrix community!
  • 0

Problem with Published Applications launching process during first logon and opened session


Hieu Phan

Question

Hi everyone,
Users from my test site (WAN connection) report that it takes forever for an app to start. (note: we only use published App through Web Interface 5.4, and Citrix receiver 13 is installed on all clients)

.. so I've been telling the users that the delay is a normal symptom from Windows 2008 since the server do a lot of work in the backend to Prepare Desktop and stuff.

However, lately, a lot of users notified me that even with applications are already opened (session established), when they start another app, it takes a long time to start too. I look at the Citrix Management console and saw that all applications from one user are in 1 single session ID. I cannot understand why it takes a long time to open.

When i tried to duplicate the issue myself at home, I didn't get it. Let's say if I already had Outlook open, excel or word would open right away when I clicked on them (no logon or preparing desktop message)

however, I can replicate the issue easily when i connect to the user's PC. below is how I can replicate
1.) Logon as user
2.) start an app. (Outlook for example)
3.) Wait till outlook is opened and functioning, start another published app (word, excel or a network folder published using explorer.exe)
4.) This is the symptom: The Citrix Receiver windows will pop up again, and go through the preparing desktop/session process. Then it will disappear, and all opened applications will disappear for a minute or so. After that, all of them will appear again, under one session. (outlook, and the newly started applications)

Do you guys know what is going on here? I've been having so many problem with Logon Delay and application startup with XenApp 6.5

Link to comment

6 answers to this question

Recommended Posts

  • 0

Any luck with fixing this?

We have the same problem but I see it as two problems.

1. After starting the first application and then starting the second one it gives you the same symptom, launching, disconnecting and then reconnecting.. the third, fouth application starts directly.
(There is a patch for this and that made it work, sometimes.. like if you have dual screens to never works but sometimes on a special screen it works. )

2. Then I saw something else now when I installed Receiver 3.3 and that is, every single application I start the darn windows shows up for 3-4 seconds saying "Preparing Word" .. really annoying. Happens in both X6 (abit faster though) and in X6.5.

Link to comment
  • 0

http://support.citrix.com/article/CTX134882

After Session Reliability times out, launching a new instance of an application can cause the session to disconnect and reconnect during the first attempt. The issue occurs when session sharing fails to work and RDP disconnects the session while attempting to create a new session as each user is restricted to a single session.

[From XA650R01W2K8R2X64030][#LA2049]

Link to comment
  • 0

I´ve been looking for a solution for the disconnection of the second app for a few months now and R01 did not solve the problem. What finally solved the problem was changing from OverrideIcaClientname=On to OverrideIcaClientname=Off in the webinterface.conf for both folders

C:\inetpub\wwwroot\Citrix\PNAgent\conf
C:\inetpub\wwwroot\Citrix\XenApp\conf

I was very sceptic about this change but after trying Everything else I though, what the hell, its Worth a test. And it worked! If someone out there has a clue on how this setting could have helped I would appreciate it.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...