Jump to content
Welcome to our new Citrix community!

Replace XML response

Grega Zoubek

Recommended Posts

Hi gurus....

I want to do what seems to be pretty straight forward task - replace server response (body). Trick is that it is in XML format. 

If I use GUI and paste following syntax:

"<?xml version="1.0" encoding="utf-8"?>", GUI will take it but once I return to rewrite action, I only see "" :). Log shows following action

set rewrite action VPN_Store_Force_rw_act -target "http.RES.BODY(100000)" -stringBuilderExpr """"" 

Looks like all between <> is deleted. Tried escaping characters in GUI with , but result is the same. Tried also CLI ,but that would result in similar error as well.

Is there any other way to use GT / LT symbols or to insert XML message in the response body?

Thank you,


Link to comment
Share on other sites

  • 2 weeks later...

Hi Grega,

This looks like a bug, we will work on getting it resolved on GUI. However as you faced the same issue on CLI side as well, but we tried with the same syntax as you have given and it worked for us.

Attaching the screenshot for your reference.MicrosoftTeams-image(14)(1).thumb.png.a9d708f086f9b259eae1c780ac022d65.png

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...